summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-07-05 16:39:40 +0100
committerChristopher Baines <mail@cbaines.net>2020-07-05 16:39:40 +0100
commit6ee7468758d7c043692ae8c0b5e130fa4eabe94c (patch)
tree40a27743025b281f321659c855895615d4b86a80 /gnu/packages/llvm.scm
parentff814b8f23035565d428a47dfd4766254215c76c (diff)
downloadguix-patches-6ee7468758d7c043692ae8c0b5e130fa4eabe94c.tar
guix-patches-6ee7468758d7c043692ae8c0b5e130fa4eabe94c.tar.gz
gnu: python-llvmlite: Use specific commit for llvm patch URLs.
As this commit [1] appears to affect the patches, including the v0.30.0 tag (so the tag must have been changed). 1: https://github.com/numba/llvmlite/commit/cdd99deb32f9d48aadb0f7407fb8ad06f6a8ce6c * gnu/packages/llvm.scm (python-llvmlite)[inputs]: Use a specific commit for the patches.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm48
1 files changed, 26 insertions, 22 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 7cd9543036..aee32b0722 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -949,28 +949,32 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
`(#:tests? #f))
(inputs
`(("llvm"
- ,(package
- (inherit llvm-7)
- (source (origin
- (inherit (package-source llvm-7))
- (patches
- (list
- (origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com/numba/"
- "llvmlite/v" version "/conda-recipes/"
- "D47188-svml-VF.patch"))
- (sha256
- (base32
- "0wxhgb61k17f0zg2m0726sf3hppm41f8jar2kkg2n8sl5cnjj9mr")))
- (origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com/numba/"
- "llvmlite/v" version "/conda-recipes/"
- "twine_cfg_undefined_behavior.patch"))
- (sha256
- (base32
- "07h71n2m1mn9zcfgw04zglffknplb233zqbcd6pckq0wygkrxflp")))))))))))
+ ,(let ((patches-commit "486edd5fb2a6667feb5c865f300c0da73785434a"))
+ (package
+ (inherit llvm-7)
+ (source
+ (origin
+ (inherit (package-source llvm-7))
+ (patches
+ (list
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/numba/"
+ "llvmlite/" patches-commit "/conda-recipes/"
+ "D47188-svml-VF.patch"))
+ (sha256
+ (base32
+ "0wxhgb61k17f0zg2m0726sf3hppm41f8jar2kkg2n8sl5cnjj9mr")))
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/numba/"
+ "llvmlite/" patches-commit "/conda-recipes/"
+ "twine_cfg_undefined_behavior.patch"))
+ (sha256
+ (base32
+ "07h71n2m1mn9zcfgw04zglffknplb233zqbcd6pckq0wygkrxflp"))))))))))))
(home-page "http://llvmlite.pydata.org")
(synopsis "Wrapper around basic LLVM functionality")
(description