summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-24 00:36:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-24 17:10:23 +0100
commit501672d754f44d6e5e9f9de0886281158f9b363f (patch)
tree922f685351297be25f70365914789a56b0c50065 /gnu/packages/llvm.scm
parent52f9c3b88ac9890db666d3de0e82063281db97f7 (diff)
downloadguix-patches-501672d754f44d6e5e9f9de0886281158f9b363f.tar
guix-patches-501672d754f44d6e5e9f9de0886281158f9b363f.tar.gz
gnu: clang: Use the correct CLANG-RUNTIME for versions 6 and 7.
* gnu/packages/llvm.scm (clang-7): Use CLANG-RUNTIME-7. (clang-6): Use CLANG-RUNTIME-6.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index effd2793d3..865657455c 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -409,7 +409,7 @@ output), and Binutils.")
"065ybd8fsc4h2hikbdyricj6pyv4r7r7kpcikhb2y5zf370xybkq"))
(define-public clang-7
- (clang-from-llvm llvm-7 clang-runtime
+ (clang-from-llvm llvm-7 clang-runtime-7
"067lwggnbg0w1dfrps790r5l6k8n5zwhlsw7zb6zvmfpwpfn4nx4"
#:patches '("clang-7.0-libc-search-path.patch")))
@@ -433,7 +433,7 @@ output), and Binutils.")
"1fcr3jn24yr8lh36nc0c4ikli4744i2q9m1ik67p1jymwwaixkgl"))
(define-public clang-6
- (clang-from-llvm llvm-6 clang-runtime
+ (clang-from-llvm llvm-6 clang-runtime-6
"0rxn4rh7rrnsqbdgp4gzc8ishbkryhpl1kd3mpnxzpxxhla3y93w"
#:patches '("clang-6.0-libc-search-path.patch")))