summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-28 20:53:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-28 20:53:20 +0200
commit4289d1d71cbbb1895354ec3b0cb8c99a4ce9f9be (patch)
treed3c85ab7c3e6080bf84402028f5e8514d5520bbb /gnu/packages/llvm.scm
parent4ee2cce327ce839f471fb28a095fe7299ed822af (diff)
downloadguix-patches-4289d1d71cbbb1895354ec3b0cb8c99a4ce9f9be.tar
guix-patches-4289d1d71cbbb1895354ec3b0cb8c99a4ce9f9be.tar.gz
gnu: python-llvmlite: Build against LLVM 7.
This is a follow-up to commit c5296e205b65a9b53553cf45be2ab223d5e82df5. * gnu/packages/llvm.scm (llvm-7, clang-runtime-7, clang-7): New public variables. (python-llvmlite)[inputs]: Inherit from LLVM-7 instead of LLVM.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm26
1 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 732ffc0823..faf9e40049 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -371,6 +371,28 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
"0svk1f70hvpwrjp6x5i9kqwrqwxnmcrw5s7f4cxyd100mdd12k08"
#:patches '("clang-7.0-libc-search-path.patch")))
+(define-public llvm-7
+ (package
+ (inherit llvm)
+ (version "7.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "16s196wqzdw4pmri15hadzqgdi926zln3an2viwyq0kini6zr3d3"))))))
+
+(define-public clang-runtime-7
+ (clang-runtime-from-llvm
+ llvm-7
+ "065ybd8fsc4h2hikbdyricj6pyv4r7r7kpcikhb2y5zf370xybkq"))
+
+(define-public clang-7
+ (clang-from-llvm llvm-7 clang-runtime
+ "067lwggnbg0w1dfrps790r5l6k8n5zwhlsw7zb6zvmfpwpfn4nx4"
+ #:patches '("clang-7.0-libc-search-path.patch")))
+
(define-public llvm-6
(package
(inherit llvm)
@@ -542,9 +564,9 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(inputs
`(("llvm"
,(package
- (inherit llvm)
+ (inherit llvm-7)
(source (origin
- (inherit (package-source llvm))
+ (inherit (package-source llvm-7))
(patches
(list
(origin