summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-27 17:30:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-27 18:20:36 +0200
commitf0b925038255e0e6909bad14115007cc34590f3a (patch)
tree8dad3b61e94e3574a2bad47282f4a238316db97c /gnu/packages/lisp.scm
parent9401cb54fc7384bbfd85c57cbeef02d94e804f60 (diff)
downloadguix-patches-f0b925038255e0e6909bad14115007cc34590f3a.tar
guix-patches-f0b925038255e0e6909bad14115007cc34590f3a.tar.gz
gnu: ccl: Update to 1.12.1.
* gnu/packages/lisp.scm (ccl): Update to 1.12.1. [inputs]: Keep using the 1.12 bootstrap for ARM.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index f6df3ef824..082eb920be 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -598,7 +598,9 @@ statistical profiler, a code coverage tool, and many other extensions.")
;; it, as is the case for SBCL, but I know of no attempt to do so."
(package
(name "ccl")
- (version "1.12")
+ ;; XXX When updating this package, check whether we can simply append
+ ;; VERSION to the ccl-bootstrap URL again, instead of per architecture.
+ (version "1.12.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -607,7 +609,7 @@ statistical profiler, a code coverage tool, and many other extensions.")
(file-name (git-file-name "ccl" version))
(sha256
(base32
- "0kxr24d2fzsmpsilijpwwfl6g89y7fcrwb80kai5nx9pwgxmjbp3"))))
+ "1zz291lvsrr7pps8wfl2kdxsnzjngqi4v3mil14pga4r5zanmsi7"))))
(build-system gnu-build-system)
;; CCL consists of a "lisp kernel" and "heap image", both of which are
;; shipped in precompiled form in source tarballs. The former is a C
@@ -619,20 +621,20 @@ statistical profiler, a code coverage tool, and many other extensions.")
,(origin
(method url-fetch)
(uri (string-append
- "https://github.com/Clozure/ccl/releases/download/v" version "/"
+ "https://github.com/Clozure/ccl/releases/download/v"
(match (%current-system)
- ("armhf-linux" "linuxarm")
+ ("armhf-linux" "1.12/linuxarm")
;; XXX: This source only works on x86, but provide it as a
;; catch-all to prevent errors when querying this package
;; on unsupported platforms.
- (_ "linuxx86"))
+ (_ "1.12.1/linuxx86"))
".tar.gz"))
(sha256
(base32
(match (%current-system)
("armhf-linux"
"0x4bjx6cxsjvxyagijhlvmc7jkyxifdvz5q5zvz37028va65243c")
- (_ "15l7cfa4a7jkfwdzsfm4q3n22jnb57imxahpql3h77xin57v1gbz"))))))))
+ (_ "0ll017ajcfsyx8f7zsy4394y8xxvz40iz0gcsmznp0n3mf0xi67c"))))))))
(native-inputs
`(("cl-asdf" ,cl-asdf)
("m4" ,m4)))