summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 15:19:49 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 15:44:24 +0100
commitcfff8ebcaf6235610846a368210d5a9fcf05eb69 (patch)
treeab3ea106dc7a3ff4430883ed075495bb4838cfda /gnu/packages/lisp.scm
parent877aa9c3980d47c3572d50dea980774641ddab6c (diff)
downloadguix-patches-cfff8ebcaf6235610846a368210d5a9fcf05eb69.tar
guix-patches-cfff8ebcaf6235610846a368210d5a9fcf05eb69.tar.gz
Revert "gnu: sbcl: Update to 1.5.9."
The boot0 package won't be needed anymore with 2.0.0. This reverts commit edf8152563a898438708ec9b2b17284a9d55d271.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm60
1 files changed, 14 insertions, 46 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a3ac957f63..452f58b39d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -74,7 +74,6 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xorg)
- #:use-module (srfi srfi-1)
#:use-module (ice-9 match))
(define (asdf-substitutions lisp)
@@ -319,9 +318,9 @@ high-level, object-oriented functional programming language. CLISP includes
an interpreter, a compiler, a debugger, and much more.")
(license license:gpl2+)))
-(define sbcl-boot0
+(define-public sbcl
(package
- (name "sbcl-boot0")
+ (name "sbcl")
(version "1.5.8")
(source
(origin
@@ -358,8 +357,13 @@ an interpreter, a compiler, a debugger, and much more.")
;; 2019-09-05, ECL was last updated in 2016 while CLISP was last updated
;; in 2010.
;;
- ;; For now we stick to CLISP for all systems.
- `(("clisp" ,clisp)
+ ;; For now we stick to CLISP for all systems. We keep the `match' here to
+ ;; make it easier to change the host compiler for various architectures.
+ `(,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ `(("clisp" ,clisp)))
+ (_
+ `(("clisp" ,clisp))))
("which" ,which)
("inetutils" ,inetutils) ;for hostname(1)
("ed" ,ed)
@@ -427,7 +431,11 @@ an interpreter, a compiler, a debugger, and much more.")
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CC" "gcc")
- (invoke "sh" "make.sh" "clisp"
+ (invoke "sh" "make.sh" ,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ `("clisp"))
+ (_
+ `("clisp")))
(string-append "--prefix="
(assoc-ref outputs "out"))
"--with-sb-core-compression"
@@ -485,46 +493,6 @@ statistical profiler, a code coverage tool, and many other extensions.")
(license (list license:public-domain license:bsd-2
(license:x11-style "file://src/code/loop.lisp")))))
-(define-public sbcl
- ;; Since 1.5.9, SBCL requires itself to build.
- ;; See https://bugs.launchpad.net/sbcl/+bug/1855272.
- (package
- (inherit sbcl-boot0)
- (name "sbcl")
- (version "1.5.9")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
- version "-source.tar.bz2"))
- (sha256
- (base32 "1dmrlklil7x3j68mwmjfpd71vkphr24s4rx6d61jpc54x0jhvnyb"))
- (modules '((guix build utils)))
- (snippet
- ;; Add sbcl-bundle-systems to 'default-system-source-registry'.
- `(begin
- (substitute* "contrib/asdf/asdf.lisp"
- ,@(asdf-substitutions name))
- #t))))
- (build-system gnu-build-system)
- (outputs '("out" "doc"))
- (native-inputs
- `(("sbcl" ,sbcl-boot0)
- ,@(fold alist-delete (package-native-inputs sbcl-boot0)
- '("clisp"))))
- (arguments
- (substitute-keyword-arguments (package-arguments sbcl-boot0)
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" "gcc")
- (invoke "sh" "make.sh" "sbcl"
- (string-append "--prefix="
- (assoc-ref outputs "out"))
- "--with-sb-core-compression"
- "--with-sb-xref-for-internals")))))))))
-
(define-public ccl
;; Warning: according to upstream, CCL is not bootstrappable.
;; See https://github.com/Clozure/ccl/issues/222 from 2019-09-02: