summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-07-06 20:49:40 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-11 23:15:00 +0200
commitc894b80324d82f2f807578efa1de792ed1331eb3 (patch)
treef3e2ae719f4b176971cb866ed60e5fac5d8f64f4 /gnu/packages/lisp.scm
parent3fb666bd40761a102dfb1e52b8ec34f104151c8a (diff)
downloadguix-patches-c894b80324d82f2f807578efa1de792ed1331eb3.tar
guix-patches-c894b80324d82f2f807578efa1de792ed1331eb3.tar.gz
gnu: sbcl-clx: Update to 0.7.5.
* gnu/packages/lisp.scm (sbcl-clx): Update to 0.7.5. [origin]: Drop "clx-remove-demo.patch" and the snippet that removes demo code. * gnu/packages/patches/clx-remove-demo.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm56
1 files changed, 22 insertions, 34 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3aa2429595..884d00d935 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
@@ -930,42 +930,30 @@ ANSI-compliant Common Lisp implementations.")
(sbcl-package->cl-source-package sbcl-cl-unicode))
(define-public sbcl-clx
- (let ((revision "1")
- (commit "1c62774b03c1cf3fe6e5cb532df8b14b44c96b95"))
- (package
- (name "sbcl-clx")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/sharplispers/clx.git")
- (commit commit)))
- (sha256
- (base32 "0qffag03ns52kwq9xjns2qg1yr0bf3ba507iwq5cmx5xz0b0rmjm"))
- (file-name (string-append "clx-" version "-checkout"))
- (patches
- (list
- (search-patch "clx-remove-demo.patch")))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; These removed files cause the compiled system to crash when
- ;; loading.
- (delete-file-recursively "demo")
- (delete-file "test/trapezoid.lisp")
- (substitute* "clx.asd"
- (("\\(:file \"trapezoid\"\\)") ""))
- #t))))
- (build-system asdf-build-system/sbcl)
- (home-page "http://www.cliki.net/portable-clx")
- (synopsis "X11 client library for Common Lisp")
- (description "CLX is an X11 client library for Common Lisp. The code was
+ (package
+ (name "sbcl-clx")
+ (version "0.7.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sharplispers/clx.git")
+ (commit version)))
+ (sha256
+ (base32
+ "1vi67z9hpj5rr4xcmfbfwzmlcc0ah7hzhrmfid6lqdkva238v2wf"))
+ (file-name (string-append "clx-" version))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiasco" ,sbcl-fiasco)))
+ (home-page "http://www.cliki.net/portable-clx")
+ (synopsis "X11 client library for Common Lisp")
+ (description "CLX is an X11 client library for Common Lisp. The code was
originally taken from a CMUCL distribution, was modified somewhat in order to
make it compile and run under SBCL, then a selection of patches were added
from other CLXes around the net.")
- (license license:x11))))
+ (license license:x11)))
(define-public cl-clx
(sbcl-package->cl-source-package sbcl-clx))