summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-08 11:04:15 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-08 11:04:15 +0200
commitb0568808ad986d1597e2cd8d15d8f8d420a3438f (patch)
treeb4db143112fe1810eda71d2db0ad81b4c3ee83c0 /gnu/packages/lisp.scm
parentb138d8b19ab3c861537c8571f477876cc86353d4 (diff)
downloadguix-patches-b0568808ad986d1597e2cd8d15d8f8d420a3438f.tar
guix-patches-b0568808ad986d1597e2cd8d15d8f8d420a3438f.tar.gz
gnu: txr: Update to 268.
* gnu/packages/lisp.scm (txr): Update to 268. [arguments]: Update 'fix-tests' phase.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 838742e1b2..6d78a83dcf 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -907,7 +907,7 @@ the HTML documentation of TXR.")
(define-public txr
(package
(name "txr")
- (version "266")
+ (version "268")
(source
(origin
(method git-fetch)
@@ -916,7 +916,7 @@ the HTML documentation of TXR.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1k9mj3zaxdsylgnb8g6cq0cmp6420x7fp3nnsqdmds4gh8ib95wn"))))
+ (base32 "0q97qddbgk9356gx4xp8iip4pwj3ln03dvjfgrny76f3wmmiwsw6"))))
(build-system gnu-build-system)
(native-inputs
;; Required to build the documentation.
@@ -961,10 +961,7 @@ the HTML documentation of TXR.")
(lambda _
(substitute* (list "tests/017/realpath.tl"
"tests/017/realpath.expected")
- (("/usr/bin") "/"))
- (substitute* "tests/018/path-test.tl"
- (("/bin") (dirname (which "sh"))))
- #t))
+ (("/usr/bin") "/"))))
(replace 'configure
;; ./configure is a hand-written script that can't handle standard
;; autotools arguments like CONFIG_SHELL.