summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-09-05 11:41:35 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-05 11:41:35 +0200
commita3439b0c70d5db75d400853ebd747e1d46f1ad3d (patch)
tree6006ec3e78fd17d7949ee0d072bb25177fe3c41d /gnu/packages/lisp.scm
parent9e737b31cb58fdfea108c1686731d92b3387fa0f (diff)
downloadguix-patches-a3439b0c70d5db75d400853ebd747e1d46f1ad3d.tar
guix-patches-a3439b0c70d5db75d400853ebd747e1d46f1ad3d.tar.gz
gnu: sbcl: Use CLISP instead of unboostrappable CCL to build.
* gnu/packages/lisp.scm (sbcl)[arguments]: Build with CLISP.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm27
1 files changed, 23 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4a5b009eee..caf52018d1 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -353,11 +353,21 @@ an interpreter, a compiler, a debugger, and much more.")
;; ABCL (recent versions only)
;; CLISP (only some versions: 2.44.1 is OK, 2.47 is not)
;; XCL
- ;; CCL seems ideal then, but it unfortunately only builds reliably
- ;; on some architectures.
+ ;;
+ ;; From NEWS:
+ ;; * build enhancement: new host quirks mechanism, support for building under
+ ;; ABCL and ECL (as well as CCL, CMUCL, CLISP and SBCL itself)
+ ;;
+ ;; CCL is not bootstrappable so it won't do. CLISP 2.49 seems to work.
+ ;; ECL too. ECL builds SBCL about 20% slower than CLISP. As of
+ ;; 2019-09-05, ECL was last updated in 2016 while CLISP was last update
+ ;; in 2010.
+ ;;
+ ;; For now we stick to CLISP for all systems. We keep the `match' in to
+ ;; make it easier to change the host compiler for various architectures.
`(,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
- `(("ccl" ,ccl)))
+ `(("clisp" ,clisp)))
(_
`(("clisp" ,clisp))))
("which" ,which)
@@ -428,7 +438,7 @@ an interpreter, a compiler, a debugger, and much more.")
(setenv "CC" "gcc")
(invoke "sh" "make.sh" ,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
- `("ccl"))
+ `("clisp"))
(_
`("clisp")))
(string-append "--prefix="
@@ -488,6 +498,15 @@ statistical profiler, a code coverage tool, and many other extensions.")
(license:x11-style "file://src/code/loop.lisp")))))
(define-public ccl
+ ;; Warning: according to upstream, CCL is not bootstrappable.
+ ;; See https://github.com/Clozure/ccl/issues/222 from 2019-09-02:
+ ;;
+ ;; "As far as I know, there is no way to build CCL without an existing
+ ;; running CCL image. It was bootstrapped back in 1986 or so as
+ ;; Macintosh Common Lisp, by Gary Byers, I believe, who is no longer on
+ ;; the planet to tell us the story. It SHOULD be possible to port the
+ ;; CCL compiler to portable Common Lisp, so that ANY lisp could build
+ ;; it, as is the case for SBCL, but I know of no attempt to do so."
(package
(name "ccl")
(version "1.11.5")