summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-10-21 14:02:57 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-22 10:43:42 +0200
commit9d9a82d94dfd3fdffc23149e33886ed021cac7af (patch)
tree6685cc2fd6772f891ac7f0520bf1c4bace7e0849 /gnu/packages/lisp.scm
parentbb20a990cd06b8f6c2b2d97528bfb348f54a7ee7 (diff)
downloadguix-patches-9d9a82d94dfd3fdffc23149e33886ed021cac7af.tar
guix-patches-9d9a82d94dfd3fdffc23149e33886ed021cac7af.tar.gz
gnu: Add yason.
* gnu/packages/lisp.scm (cl-yason, sbcl-yason, ecl-yason): New variables.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5e4f9484ee..be0b876df8 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7930,3 +7930,34 @@ of function partial application and composition.")
(define-public ecl-curry-compose-reader-macros
(sbcl-package->ecl-package sbcl-curry-compose-reader-macros))
+
+(define-public sbcl-yason
+ (package
+ (name "sbcl-yason")
+ (version "0.7.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phmarek/yason.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0479rbjgbj80jpk5bby18inlv1kfp771a82rlcq5psrz65qqa9bj"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+ (synopsis "Common Lisp JSON parser/encoder")
+ (description
+ "YASON is a Common Lisp library for encoding and decoding data in the
+JSON interchange format.")
+ (home-page "https://github.com/phmarek/yason")
+ (license license:bsd-3)))
+
+(define-public cl-yason
+ (sbcl-package->cl-source-package sbcl-yason))
+
+(define-public ecl-yason
+ (sbcl-package->ecl-package sbcl-yason))