summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-06-30 16:57:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-06-30 17:01:20 +0200
commit9829f53a3f88884e245e962073528be46918ad2e (patch)
tree35339e16b0cfc8093958ade284340cecd91267b4 /gnu/packages/lisp.scm
parentaeea9a31111850283d699291cee51149fbe0fbcc (diff)
downloadguix-patches-9829f53a3f88884e245e962073528be46918ad2e.tar
guix-patches-9829f53a3f88884e245e962073528be46918ad2e.tar.gz
gnu: sbcl: Fix build on some architectures.
* gnu/packages/lisp.scm (sbcl)[arguments]: Update 'build-doc' phase to build the doc for SB-SIMD only on x86_64-linux.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 715ba14201..d59f11865b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -557,7 +557,15 @@ an interpreter, a compiler, a debugger, and much more.")
(invoke "sh" "install.sh")))
(add-after 'build 'build-doc
(lambda _
- ;; TODO: Doc is not deterministic, maybe there is a timespamp?
+ ;; Building the documentation for SB-SIMD only works when SB-SIMD
+ ;; is enabled, so far only on x86_64-linux.
+ ,@(match (%current-system)
+ ("x86_64-linux"
+ '())
+ (_
+ '((substitute* "doc/manual/generate-texinfo.lisp"
+ (("exclude '\\(\"asdf\"\\)")
+ "exclude '(\"asdf\" \"sb-simd\")")))))
(with-directory-excursion "doc/manual"
(and (invoke "make" "info")
(invoke "make" "dist")))))