summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
commit8d59c262ada2e2167196a8fb8cbebd9c329a79dd (patch)
tree85a74de8cc23a2f0179c0b9f0adfa4c274449a0c /gnu/packages/lisp.scm
parente7f0835b07d868fd447aa64c873174fa385e1699 (diff)
parenta068ed6a5f5b3535fce49ac4eca1fec82edd6fdc (diff)
downloadguix-patches-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar
guix-patches-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/algebra.scm gnu/packages/bioinformatics.scm gnu/packages/curl.scm gnu/packages/docbook.scm gnu/packages/emacs-xyz.scm gnu/packages/maths.scm gnu/packages/plotutils.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/readline.scm gnu/packages/tls.scm gnu/packages/xml.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 50af7bc396..6dfb7def72 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -400,14 +400,14 @@ an interpreter, a compiler, a debugger, and much more.")
(define-public sbcl
(package
(name "sbcl")
- (version "2.1.4")
+ (version "2.1.5")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
(sha256
- (base32 "04dxxycqhds9r1ycqx3cbavv7p4r13svl5bfakjjmlpw8qihw9lr"))))
+ (base32 "1id8r2y8hiz34lmvszikdqgrmr778jshim0fibb915assvn0fn4n"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(native-inputs
@@ -594,7 +594,9 @@ statistical profiler, a code coverage tool, and many other extensions.")
;; it, as is the case for SBCL, but I know of no attempt to do so."
(package
(name "ccl")
- (version "1.12")
+ ;; XXX When updating this package, check whether we can simply append
+ ;; VERSION to the ccl-bootstrap URL again, instead of per architecture.
+ (version "1.12.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -603,7 +605,7 @@ statistical profiler, a code coverage tool, and many other extensions.")
(file-name (git-file-name "ccl" version))
(sha256
(base32
- "0kxr24d2fzsmpsilijpwwfl6g89y7fcrwb80kai5nx9pwgxmjbp3"))))
+ "1zz291lvsrr7pps8wfl2kdxsnzjngqi4v3mil14pga4r5zanmsi7"))))
(build-system gnu-build-system)
;; CCL consists of a "lisp kernel" and "heap image", both of which are
;; shipped in precompiled form in source tarballs. The former is a C
@@ -615,20 +617,20 @@ statistical profiler, a code coverage tool, and many other extensions.")
,(origin
(method url-fetch)
(uri (string-append
- "https://github.com/Clozure/ccl/releases/download/v" version "/"
+ "https://github.com/Clozure/ccl/releases/download/v"
(match (%current-system)
- ("armhf-linux" "linuxarm")
+ ("armhf-linux" "1.12/linuxarm")
;; XXX: This source only works on x86, but provide it as a
;; catch-all to prevent errors when querying this package
;; on unsupported platforms.
- (_ "linuxx86"))
+ (_ "1.12.1/linuxx86"))
".tar.gz"))
(sha256
(base32
(match (%current-system)
("armhf-linux"
"0x4bjx6cxsjvxyagijhlvmc7jkyxifdvz5q5zvz37028va65243c")
- (_ "15l7cfa4a7jkfwdzsfm4q3n22jnb57imxahpql3h77xin57v1gbz"))))))))
+ (_ "0ll017ajcfsyx8f7zsy4394y8xxvz40iz0gcsmznp0n3mf0xi67c"))))))))
(native-inputs
`(("cl-asdf" ,cl-asdf)
("m4" ,m4)))