summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-09-16 13:54:30 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-18 11:55:42 +0200
commit7bf9577d0cddbcd8bb85c06fd2249f2d9c4ccd27 (patch)
tree31d57706fc210028ac765070a59b16e1e65485bd /gnu/packages/lisp.scm
parentb2fa53d0f6f76e773a2b0736ff370ecf456ae877 (diff)
downloadguix-patches-7bf9577d0cddbcd8bb85c06fd2249f2d9c4ccd27.tar
guix-patches-7bf9577d0cddbcd8bb85c06fd2249f2d9c4ccd27.tar.gz
gnu: Add periods.
* gnu/packages/lisp.scm (sbcl-periods, cl-periods, ecl-periods): New variables.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 37a0893d2f..362da8f646 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6972,3 +6972,36 @@ programming style and the efficiency of an iterative programming style.")
(define-public ecl-series
(sbcl-package->ecl-package sbcl-series))
+
+(define-public sbcl-periods
+ (let ((commit "983d4a57325db3c8def942f163133cec5391ec28")
+ (revision "1"))
+ (package
+ (name "sbcl-periods")
+ (version (git-version "0.0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jwiegley/periods.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z30jr3lxz3cmi019fsl4lgcgwf0yqpn95v9zkkkwgymdrkd4lga"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("local-time" ,sbcl-local-time)))
+ (synopsis "Common Lisp library for manipulating date/time objects")
+ (description
+ "Periods is a Common Lisp library providing a set of utilities for
+manipulating times, distances between times, and both contiguous and
+discontiguous ranges of time.")
+ (home-page "https://github.com/jwiegley/periods")
+ (license license:bsd-3))))
+
+(define-public cl-periods
+ (sbcl-package->cl-source-package sbcl-periods))
+
+(define-public ecl-periods
+ (sbcl-package->ecl-package sbcl-periods))