summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2021-07-13 19:38:12 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2021-07-20 10:50:04 +0200
commit59d09bfb2b69bb7e13815f5d1c1734d2db3d63d5 (patch)
tree79daefa2c7d269385f64c222b46ae387d325e8a5 /gnu/packages/lisp.scm
parent6a0658afa7388f2b9f55a2ef437ae0c2776e19b8 (diff)
downloadguix-patches-59d09bfb2b69bb7e13815f5d1c1734d2db3d63d5.tar
guix-patches-59d09bfb2b69bb7e13815f5d1c1734d2db3d63d5.tar.gz
gnu: txr: Update to 266.
* gnu/packages/lisp.scm (txr)[version]: Update to 266. [inputs]: Add bash. [arguments]<#:phases>{inhibit-doc-syms-generation}: Correct the path to doc-syms.tl to its new location. {fix-tests}: Fix another test. {fix-paths}: New phase. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index dbeeb5cd60..d8d7a7394c 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -54,6 +54,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages compression)
#:use-module (gnu packages ed)
@@ -906,7 +907,7 @@ the HTML documentation of TXR.")
(define-public txr
(package
(name "txr")
- (version "263")
+ (version "266")
(source
(origin
(method git-fetch)
@@ -915,7 +916,7 @@ the HTML documentation of TXR.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "14zaziymnbr2ld79x4h7sf88bzzzj82w3xpavmcx7mhwannb2swh"))))
+ (base32 "1k9mj3zaxdsylgnb8g6cq0cmp6420x7fp3nnsqdmds4gh8ib95wn"))))
(build-system gnu-build-system)
(native-inputs
;; Required to build the documentation.
@@ -923,7 +924,8 @@ the HTML documentation of TXR.")
("groff" ,groff)
("man2html" ,man-for-txr)))
(inputs
- `(("libffi" ,libffi)))
+ `(("bash" ,bash)
+ ("libffi" ,libffi)))
(arguments
`(#:configure-flags
(list ,(string-append "cc=" (cc-for-target))
@@ -947,14 +949,21 @@ the HTML documentation of TXR.")
;; stdlib/doc-syms.tl, which is anyway kept up to date with
;; each release (and is already compiled to stdlib/doc-syms.tlo
;; when genman.txr is run).
- (("^@\\(output \"share/txr/stdlib/doc-syms\\.tl\"\\).*" line)
+ (("^@\\(output \"stdlib/doc-syms\\.tl\"\\).*" line)
(string-append "@(do (exit))\n" line)))
#t))
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "stream.c"
+ (("/bin/sh")
+ (string-append (assoc-ref inputs "bash") "/bin/bash")))))
(add-after 'unpack 'fix-tests
(lambda _
(substitute* (list "tests/017/realpath.tl"
"tests/017/realpath.expected")
(("/usr/bin") "/"))
+ (substitute* "tests/018/path-test.tl"
+ (("/bin") (dirname (which "sh"))))
#t))
(replace 'configure
;; ./configure is a hand-written script that can't handle standard