summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 04:26:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 05:57:53 +0100
commit58fd2385208a0713885422f2e9e23e4a6d5c0898 (patch)
tree92e2d40ef088781b2d294c7e3bb36c3e1d674388 /gnu/packages/lisp.scm
parentf561aca5303aed0b0e061d67718acc27ad5279ef (diff)
downloadguix-patches-58fd2385208a0713885422f2e9e23e4a6d5c0898.tar
guix-patches-58fd2385208a0713885422f2e9e23e4a6d5c0898.tar.gz
gnu: txr: Remove input labels.
* gnu/packages/lisp.scm (txr)[native-inputs, inputs]: Remove input labels.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index f2c41a0524..8edff11cb3 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -926,14 +926,6 @@ the HTML documentation of TXR.")
(sha256
(base32 "1kp64h3ls8mddvrlaqqylrb3brckfrqvkk8049xn15mimfggg0xv"))))
(build-system gnu-build-system)
- (native-inputs
- ;; Required to build the documentation.
- `(("ghostscript" ,ghostscript)
- ("groff" ,groff)
- ("man2html" ,man-for-txr)))
- (inputs
- `(("bash" ,bash-minimal)
- ("libffi" ,libffi)))
(arguments
`(#:configure-flags
(list ,(string-append "cc=" (cc-for-target))
@@ -989,6 +981,14 @@ the HTML documentation of TXR.")
(for-each (lambda (f) (install-file f doc))
'("txr-manpage.html" "txr-manpage.pdf")))
#t)))))
+ (native-inputs
+ ;; Required to build the documentation.
+ (list ghostscript
+ groff
+ man-for-txr))
+ (inputs
+ (list bash-minimal
+ libffi))
(synopsis "General-purpose, multi-paradigm programming language")
(description
"TXR is a general-purpose, multi-paradigm programming language. It