summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-12-05 10:22:42 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-12-05 16:00:58 +0100
commit4354dacede0bb7ca73c68594753bc973ff6ca653 (patch)
treec0bafece14d39a524a930fe4bc91cc4d92878c36 /gnu/packages/lisp.scm
parentf62982d96d1ee51a0ae47c171a6cfda6efa36c78 (diff)
downloadguix-patches-4354dacede0bb7ca73c68594753bc973ff6ca653.tar
guix-patches-4354dacede0bb7ca73c68594753bc973ff6ca653.tar.gz
gnu: sbcl: Simplify 'replace-asdf' phase.
* gnu/packages/lisp.scm (sbcl)[arguments]: Remove unused 'out' variable in 'replace-asdf' phase.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a540174c88..3d446290a7 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -444,12 +444,11 @@ an interpreter, a compiler, a debugger, and much more.")
;; of ASDF we use to build software; therefore, replace the contrib
;; ASDF with the version packaged into Guix.
;; [1] - https://bugs.launchpad.net/sbcl/+bug/1823442
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key inputs #:allow-other-keys)
(let* ((cl-asdf (assoc-ref inputs "cl-asdf"))
(guix-asdf (string-append
cl-asdf
"/share/common-lisp/source/asdf/asdf.lisp"))
- (out (string-append (assoc-ref outputs "out")))
(contrib-asdf "contrib/asdf/asdf.lisp"))
(copy-file guix-asdf contrib-asdf))
#t))