summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2020-12-12 10:34:37 +0800
committerGuillaume Le Vaillant <glv@posteo.net>2020-12-14 14:27:55 +0100
commit20a964149cd51d06f3560287126111490a502581 (patch)
tree111a78907ec80b0592edaafc4f9f472a2d351241 /gnu/packages/lisp.scm
parente3f538969ef250b5a4a720834f9f6e54aaf72a19 (diff)
downloadguix-patches-20a964149cd51d06f3560287126111490a502581.tar
guix-patches-20a964149cd51d06f3560287126111490a502581.tar.gz
gnu: ecl: Remove build-stamp to improve reproducibility.
* gnu/packages/lisp.scm (ecl)[arguments]<phases>: Add "remove-build-stamp" phase. Move "wrap" phase after "remove-build-stamp" phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4592724867..f250e8804b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -258,7 +259,12 @@ interface to the Tk widget system.")
(contrib-asdf "contrib/asdf/asdf.lisp"))
(copy-file guix-asdf contrib-asdf))
#t))
- (add-after 'install 'wrap
+ (add-after 'install 'remove-build-stamp
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/ecl-" ,version "/build-stamp"))
+ #t))
+ (add-after 'remove-build-stamp 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((ecl (assoc-ref outputs "out"))
(input-path (lambda (lib path)