summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-02 21:48:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-02 21:50:03 +0200
commit2026204a13515aaa9b7814f9a6f0a60b65493bd1 (patch)
treeb0f77a8f1bd6bba1a4ba7f4d05bd734682a8e147 /gnu/packages/lisp.scm
parent8ce47c20209ad9b87e1b7595556f22b2b5e2b8a2 (diff)
downloadguix-patches-2026204a13515aaa9b7814f9a6f0a60b65493bd1.tar
guix-patches-2026204a13515aaa9b7814f9a6f0a60b65493bd1.tar.gz
gnu: slime-swank: Update to 2.24 and use asdf-build-system/source.
* gnu/packages/lisp.scm (sbcl-slime-swank): Deprecate in favour of cl-slime-swank. (cl-slime-swank): New package. (sbcl-mgl-pax): Use cl-slime-swank. * gnu/packages/web-browsers.scm (next): Use cl-slime-swank.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm46
1 files changed, 17 insertions, 29 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ba009bb7a6..2939fdc4ed 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -2327,42 +2327,27 @@ writing code that contains string literals that contain code themselves.")
(define-public ecl-pythonic-string-reader
(sbcl-package->ecl-package sbcl-pythonic-string-reader))
-(define-public sbcl-slime-swank
+;; SLIME does not have a ASDF system definition to build all of Swank. As a
+;; result, the asdf-build-system/sbcl will produce an almost empty package.
+;; Some work was done to fix this at
+;; https://github.com/sionescu/slime/tree/swank-asdf but it was never merged
+;; and is now lagging behind. Building SBCL fasls might not be worth the
+;; hassle, so let's just ship the source then.
+(define-public cl-slime-swank
(package
- (name "sbcl-slime-swank")
- (version "2.22")
+ (name "cl-slime-swank")
+ (version "2.24")
(source
(origin
(file-name (string-append name "-" version ".tar.gz"))
(method git-fetch)
(uri (git-reference
- ;; (url "https://github.com/slime/slime/")
- ;; (commit "841f61467c03dea9f38ff9d5af0e21a8aa29e8f7")
- ;; REVIEW: Do we need sionescu's patch to package SWANK?
- (url "https://github.com/sionescu/slime/")
- ;; (commit "swank-asdf")
- (commit "2f7c3fcb3ac7d50d844d5c6ca0e89b52a45e1d3a")))
+ (url "https://github.com/slime/slime/")
+ (commit (string-append "v" version))))
(sha256
(base32
- ;; "065bc4y6iskazdfwlhgcjlzg9bi2hyjbhmyjw3461506pgkj08vi"
- "0pkmg94wn4ii1zhlrncn44mdc5i6c5v0i9gbldx4dwl2yy7ibz5c"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "contrib/swank-listener-hooks.lisp"
- ((":compile-toplevel :load-toplevel ") ""))
- (substitute* "contrib/swank-presentations.lisp"
- ((":compile-toplevel :load-toplevel ") ""))
- (substitute* "swank.asd"
- ((":file \"packages\".*" all)
- (string-append all "(:file \"swank-loader-asdf\")\n")))
- (substitute* "swank-loader-asdf.lisp"
- ((":common-lisp" all) (string-append all " #:asdf")))
- #t))))
- (build-system asdf-build-system/sbcl)
- (arguments
- `(#:asd-file "swank.asd"
- #:asd-system-name "swank"))
+ "0js24x42m7b5iymb4rxz501dff19vav5pywnzv50b673rbkaaqvh"))))
+ (build-system asdf-build-system/source)
(home-page "https://github.com/slime/slime")
(synopsis "Common Lisp Swank server")
(description
@@ -2371,6 +2356,9 @@ processes that doesn't run under Emacs. Lisp processes created by
@command{M-x slime} automatically start the server.")
(license (list license:gpl2+ license:public-domain))))
+(define-public sbcl-slime-swank
+ (deprecated-package "sbcl-slime-swank" cl-slime-swank))
+
(define-public sbcl-mgl-pax
(let ((commit "818448418d6b9de74620f606f5b23033c6082769"))
(package
@@ -2395,7 +2383,7 @@ processes that doesn't run under Emacs. Lisp processes created by
("ironclad" ,sbcl-ironclad)
("named-readtables" ,sbcl-named-readtables)
("pythonic-string-reader" ,sbcl-pythonic-string-reader)
- ("swank" ,sbcl-slime-swank)))
+ ("swank" ,cl-slime-swank)))
(synopsis "Exploratory programming environment and documentation generator")
(description
"PAX provides an extremely poor man's Explorable Programming