summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-11-30 12:28:38 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-11-30 12:28:38 +0100
commit074236d19796577b2f55b3c7030c14242efa8f3f (patch)
tree45ba525b356ac6d437b7418eb4dcd8902e258579 /gnu/packages/lisp.scm
parent85821dcd33d7856ab57459f9afb46b32a862bf52 (diff)
downloadguix-patches-074236d19796577b2f55b3c7030c14242efa8f3f.tar
guix-patches-074236d19796577b2f55b3c7030c14242efa8f3f.tar.gz
gnu: clisp: Enable ASDF module and parallel build, remove old patch.
* gnu/packages/lisp.scm (clisp)[source]: Remove patch that does not seem to be needed anymore. [arguments]: Remove (obsolete?) #:build keyword. Enable ASDF and explicitly enable ffcall, readline, sigsegv. Enable parallel-build since they seem to work now.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a3139c21c8..70f0ceadb0 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -331,8 +331,7 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(commit "clisp-2.49.92-2018-02-18")))
(file-name (git-file-name name version))
(sha256
- (base32 "0k2dmgl0miz3767iks4p0mvp6xw0ysyxhjpklyh11j010rmh6hqb"))
- (patches (search-patches "clisp-remove-failing-test.patch"))))
+ (base32 "0k2dmgl0miz3767iks4p0mvp6xw0ysyxhjpklyh11j010rmh6hqb"))))
(build-system gnu-build-system)
(inputs `(("libffcall" ,libffcall)
("ncurses" ,ncurses)
@@ -346,8 +345,11 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
'())
"--with-dynamic-ffi"
"--with-dynamic-modules"
+ "--with-ffcall"
+ "--with-readline"
+ "--with-sigsegv"
+ "--with-module=asdf"
"--with-module=rawsock")
- #:build #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-sh-and-pwd
@@ -365,9 +367,7 @@ supporting ASDF, Sockets, Gray streams, MOP, and other useful components.")
(("/bin/sh") "sh"))
(substitute* '("src/clisp-link.in")
(("/bin/pwd") "pwd"))
- #t)))
- ;; Makefiles seem to have race conditions.
- #:parallel-build? #f))
+ #t)))))
(home-page "https://clisp.sourceforge.io/")
(synopsis "A Common Lisp implementation")
(description