summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-23 16:34:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 16:34:34 +0300
commitfffe9a152947801881edb979324183990859f340 (patch)
tree3036a423970745800c42a3362968a4cce222d3da /gnu/packages/lisp-xyz.scm
parentb2447228798bc234ca289daeeb381e77f202039b (diff)
downloadguix-patches-fffe9a152947801881edb979324183990859f340.tar
guix-patches-fffe9a152947801881edb979324183990859f340.tar.gz
gnu: sbcl-md5: Don't use unstable tarball.
* gnu/packages/lisp-xyz.scm (sbcl-md5)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c89ad4aef9..fd9422a8ba 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3592,11 +3592,13 @@ process form data posted with HTTP POST method using enctype
(version "2.0.4")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/pmai/md5/archive/release-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pmai/md5")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name "md5" version))
(sha256
- (base32 "19yl9n0pjdz5gw4qi711lka97xcd9f81ylg434hk7jwn9f2s6w11"))))
+ (base32 "1waqxzm7vlc22n92hv8r27anlvvjkkh9slhrky1ww7mdx4mmxwb8"))))
(build-system asdf-build-system/sbcl)
(home-page "https://github.com/pmai/md5")
(synopsis