summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-22 12:10:07 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-22 12:10:07 +0100
commitf96a65eb1bad19a7dea8a915179791800b3cf1eb (patch)
tree1e1bdcb1079f0914a07680822d18d12ca3b1e357 /gnu/packages/lisp-xyz.scm
parent7c424b3831ce891bd536831a04ff0e38f58fa045 (diff)
downloadguix-patches-f96a65eb1bad19a7dea8a915179791800b3cf1eb.tar
guix-patches-f96a65eb1bad19a7dea8a915179791800b3cf1eb.tar.gz
gnu: sbcl-cl-gobject-introspection: Update to 20210121.
* gnu/packages/lisp-xyz.scm (sbcl-cl-gobject-introspection): Update to 20210121. [arguments]: Re-enable tests now that upstream has fixed them.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1c98c032c8..bddcaec143 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6500,8 +6500,8 @@ ability to store all Common Lisp data types into streams.")
(sbcl-package->ecl-package sbcl-cl-store))
(define-public sbcl-cl-gobject-introspection
- (let ((commit "7b703e2384945ea0ac39d9b766de434a08d81560")
- (revision "0"))
+ (let ((commit "d0136c8d9ade2560123af1fc55bbf70d2e3db539")
+ (revision "1"))
(package
(name "sbcl-cl-gobject-introspection")
(version (git-version "0.3" revision commit))
@@ -6515,7 +6515,7 @@ ability to store all Common Lisp data types into streams.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zcqd2qj14f6b38vys8gr89s6cijsp9r8j43xa8lynilwva7bwyh"))))
+ "0dz0r73pq7yhz2iq2jnkq977awx2zws2qfxdcy33329sys1ii32p"))))
(build-system asdf-build-system/sbcl)
(inputs
`(("alexandria" ,sbcl-alexandria)
@@ -6527,12 +6527,9 @@ ability to store all Common Lisp data types into streams.")
(native-inputs
`(("fiveam" ,sbcl-fiveam)))
(arguments
- ;; TODO: Tests fail, see
- ;; https://github.com/andy128k/cl-gobject-introspection/issues/70.
- '(#:tests? #f
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-after (quote unpack) (quote fix-paths)
+ (add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/init.lisp"
(("libgobject-2\\.0\\.so")