summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-03-10 15:26:00 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-03-10 15:28:26 +0100
commitaa350909c194a3ac8bc5e5bead86694df6402cde (patch)
treedb50e4eee0b90c992a8846e6f81528241dc85267 /gnu/packages/lisp-xyz.scm
parentc175bca67a86a619b13a3cc33d452a6b22c15f0f (diff)
downloadguix-patches-aa350909c194a3ac8bc5e5bead86694df6402cde.tar
guix-patches-aa350909c194a3ac8bc5e5bead86694df6402cde.tar.gz
gnu: cl-reexport: Several fixes.
* gnu/packages/lisp-xyz.scm (sbcl-cl-reexport)[source]: Hardcode URL. [inputs]: Use new style. [synopsis, description]: Fix them.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8c27339969..fc18742e3c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5792,20 +5792,22 @@ XSD type library.")
(origin
(method git-fetch)
(uri (git-reference
- (url home-page)
+ (url "https://github.com/takagi/cl-reexport")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-reexport" version))
(sha256
(base32
"1cwpn1m3wrl0fl9plznn7p464db646gnfc8zkyk97dyxski2aq0x"))))
(inputs
- `(("alexandria" ,sbcl-alexandria)))
+ (list sbcl-alexandria))
(arguments
;; TODO: Tests fail because cl-test-more is missing, but I can't find it online.
`(#:tests? #f))
- (synopsis "HTTP cookie manager for Common Lisp")
- (description "cl-cookie is a Common Lisp library featuring parsing of
-cookie headers, cookie creation, cookie jar creation and more.")
+ (synopsis "Reexport external symbols in other Common Lisp packages")
+ (description
+ "Cl-reexport makes a package reexport symbols which are external
+symbols in other Common Lisp packages. This fanctionality is intended to be
+used with (virtual) hierarchical packages.")
(license license:llgpl))))
(define-public cl-reexport