summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-03-26 23:28:27 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-29 10:25:23 +0200
commit96df3fe765cc5dda3b31d4cbe29ed3ba9cf3d254 (patch)
tree53920b3f36cb7a1b9d9677ef488d23d270bcb750 /gnu/packages/lisp-xyz.scm
parent4f4ea0824000445f9d891fd519d4f2c3a47b7a90 (diff)
downloadguix-patches-96df3fe765cc5dda3b31d4cbe29ed3ba9cf3d254.tar
guix-patches-96df3fe765cc5dda3b31d4cbe29ed3ba9cf3d254.tar.gz
gnu: Add cl-bodge-math.
* gnu/packages/lisp-xyz.scm: (sbcl-bodge-math, cl-bodge-math, ecl-bodge-math): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 462e842171..ab258efdfd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15484,3 +15484,35 @@ immediately loaded.")
(define-public cl-quickproject
(sbcl-package->cl-source-package sbcl-quickproject))
+
+(define-public sbcl-bodge-math
+ (let ((commit "9159b7faf88d440024c07110dbef2abddb20b9af")
+ (revision "1"))
+ (package
+ (name "sbcl-bodge-math")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/borodust/bodge-math")
+ (commit commit)))
+ (file-name (git-file-name "bodge-math" version))
+ (sha256
+ (base32 "0r3vnl9lywn4ksy34apcv6j825qp7l1naddawr14v4lwacndb80v"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("bodge-utilities" ,sbcl-bodge-utilities)
+ ("rtg-math" ,sbcl-rtg-math)))
+ (home-page "https://github.com/borodust/bodge-math")
+ (synopsis "Common Lisp core math utilities of BODGE library collection")
+ (description
+ "This Common Lisp package contains the core math utilities of the
+@emph{Bodge} library collection.")
+ (license license:expat))))
+
+(define-public ecl-bodge-math
+ (sbcl-package->ecl-package sbcl-bodge-math))
+
+(define-public cl-bodge-math
+ (sbcl-package->cl-source-package sbcl-bodge-math))