summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-05-21 10:39:57 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-05-21 10:42:36 +0200
commit94b28247d1b976e9c01c75794663603b7b81eaeb (patch)
tree40653c908b02aee5b5a153454c3efcc47b8c05fb /gnu/packages/lisp-xyz.scm
parent624eac9a6ecffefdaed04aa5678cab06627517af (diff)
downloadguix-patches-94b28247d1b976e9c01c75794663603b7b81eaeb.tar
guix-patches-94b28247d1b976e9c01c75794663603b7b81eaeb.tar.gz
gnu: cl-burgled-batteries3: Fix build with Python 3.9.
* gnu/packages/lisp-xyz.scm (sbcl-burgled-batteries3)[arguments]: Rename 'adjust-for-python-3.8' phase to 'adjust-for-python-3.9' and update it. [inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d245bba7f7..3b8591fb4a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5495,7 +5495,7 @@ high-level way. This library provides such operators.")
(uri (git-reference
(url "https://github.com/snmsts/burgled-batteries3")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-burgled-batteries3" version))
(sha256
(base32
"1nzn7jawrfajyzwfnzrg2cmn9xxadcqh4szbpg0jggkhdkdzz4wa"))
@@ -5519,21 +5519,21 @@ high-level way. This library provides such operators.")
(setenv "BB_PYTHON3_DYLIB"
(string-append python "/lib/libpython3.so"))
#t)))
- (add-after 'unpack 'adjust-for-python-3.8
+ (add-after 'unpack 'adjust-for-python-3.9
(lambda _
- ;; This method is no longer part of the public API.
+ ;; These methods are no longer part of the public API.
(substitute* "ffi-interface.lisp"
- ((".*PyEval_ReInitThreads.*")
- ""))
- #t)))))
+ ((".*PyEval_ReInitThreads.*") "")
+ ((".*\"PyErr_Warn\".*") "")
+ ((".*\"PyFloat_ClearFreeList\".*") "")))))))
(native-inputs
(list sbcl-cl-fad sbcl-lift sbcl-cl-quickcheck))
(inputs
- `(("python" ,python)
- ("sbcl-cffi" ,sbcl-cffi)
- ("sbcl-alexandria" , sbcl-alexandria)
- ("sbcl-parse-declarations-1.0" ,sbcl-parse-declarations)
- ("sbcl-trivial-garbage" ,sbcl-trivial-garbage)))
+ (list python
+ sbcl-alexandria
+ sbcl-cffi
+ sbcl-parse-declarations
+ sbcl-trivial-garbage))
(synopsis "Bridge between Python and Lisp (FFI bindings, etc.)")
(description
"This package provides a shim between Python3 (specifically, the