summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 16:43:18 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 17:14:08 +0200
commit74fb7f900e046e65d99563ba439526c51039f9d4 (patch)
tree945d28eb9e0a48fe476843a4558f2cb07e97afb1 /gnu/packages/lisp-xyz.scm
parent5a08660ecb965783f581b95704c150e12d721891 (diff)
downloadguix-patches-74fb7f900e046e65d99563ba439526c51039f9d4.tar
guix-patches-74fb7f900e046e65d99563ba439526c51039f9d4.tar.gz
gnu: cl-cxml: Remove ASD fix since our build system supports component-less asd.
* gnu/packages/lisp-xyz.scm (cl-cxml)[arguments]: Remove 'remove-component phase.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 09d25f0764..d2c7560418 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5719,22 +5719,7 @@ offered, one SAX-like, the other similar to StAX.")
(install-file "catalog.dtd"
(string-append
(assoc-ref outputs "out")
- "/lib/" (%lisp-type)))))
- (add-after 'create-asd 'remove-component
- ;; XXX: The original .asd has no components, but our build system
- ;; creates an entry nonetheless. We need to remove it for the
- ;; generated .asd to load properly. See trivia.trivial for a
- ;; similar problem.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (asd (string-append out "/lib/sbcl/cxml.asd")))
- (substitute* asd
- ((" :components
-")
- ""))
- (substitute* asd
- ((" *\\(\\(:compiled-file \"cxml--system\"\\)\\)")
- ""))))))))))
+ "/lib/" (%lisp-type))))))))))
(define-public cl-cxml
(sbcl-package->cl-source-package sbcl-cxml))