summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-03-03 10:15:11 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-03-03 16:21:21 +0100
commit6f32cbe480e321d411c2a64247ed8a056c00adc2 (patch)
tree465e3f6b042dfa778e982a6e100d0c76ff956246 /gnu/packages/lisp-xyz.scm
parent4572cf5129063545e796c83d32fc6b2c92220a78 (diff)
downloadguix-patches-6f32cbe480e321d411c2a64247ed8a056c00adc2.tar
guix-patches-6f32cbe480e321d411c2a64247ed8a056c00adc2.tar.gz
gnu: cl-flexichain: Update to 1.5.1-2.9af644a.
* gnu/packages/lisp-xyz.scm (sbcl-flexichain): Update to 1.5.1-2.9af644a. [inputs]: Add trivial-garbage.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8af7d2a6ac..9b9338197e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -884,22 +884,23 @@ spatially-extended data.")
(define-public sbcl-flexichain
;; There are no releases.
- (let ((commit "13d2a6c505ed0abfcd4c4ec7d7145059b06855d6")
- (revision "1"))
+ (let ((commit "9af644a6323f303a936a391b956babcbfe7b0c67")
+ (revision "2"))
(package
(name "sbcl-flexichain")
- (version "1.5.1")
+ (version (git-version "1.5.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/robert-strandh/Flexichain")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-flexichain" version))
(sha256
- (base32
- "0pfyvhsfbjd2sjb30grfs52r51a428xglv7bwydvpg2lc117qimg"))))
+ (base32 "1ivkffnkc1iqmpl1p1rgyfbbgjmjcid4iszvdql1jjz324lq94g6"))))
(build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-trivial-garbage))
(home-page "https://github.com/robert-strandh/Flexichain.git")
(synopsis "Dynamically add elements to or remove them from sequences")
(description