summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-03-10 18:19:20 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-03-10 18:20:05 +0100
commit6e70211b20537b018e639b0114d3ccddd4924acb (patch)
tree948e89e6fe2773026259f924f29a84531f8f375e /gnu/packages/lisp-xyz.scm
parent336088d5216da023983801201b7cecdafe31ff48 (diff)
downloadguix-patches-6e70211b20537b018e639b0114d3ccddd4924acb.tar
guix-patches-6e70211b20537b018e639b0114d3ccddd4924acb.tar.gz
gnu: sbcl-quri: Update to 0.3.0.
* gnu/packages/lisp-xyz.scm (sbcl-quri): Update to 0.3.0.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm60
1 files changed, 29 insertions, 31 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index eb84a9afdd..e15185339b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4331,38 +4331,36 @@ addition, removal, and random selection.")
(sbcl-package->ecl-package sbcl-map-set))
(define-public sbcl-quri
- (let ((commit "d7f2720568146c6674187f625f115925e6364a7f")
- (revision "4"))
- (package
- (name "sbcl-quri")
- (version (git-version "0.1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fukamachi/quri")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0yrcvz5ksfr7x8yx741vp65il0fxxaskppq3iyk9bq895s1jn37w"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- ;; Test system must be loaded before, otherwise tests fail with:
- ;; Component QURI-ASD::QURI-TEST not found, required by #<SYSTEM
- ;; "quri">.
- '(#:asd-systems '("quri-test"
- "quri")))
- (native-inputs `(("sbcl-prove" ,sbcl-prove)))
- (inputs `(("sbcl-babel" ,sbcl-babel)
- ("sbcl-split-sequence" ,sbcl-split-sequence)
- ("sbcl-cl-utilities" ,sbcl-cl-utilities)
- ("sbcl-alexandria" ,sbcl-alexandria)))
- (home-page "https://github.com/fukamachi/quri")
- (synopsis "Yet another URI library for Common Lisp")
- (description
- "QURI (pronounced \"Q-ree\") is yet another URI library for Common
+ (package
+ (name "sbcl-quri")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fukamachi/quri")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pkvpiwwhx2fcknr7x47h7036ypkg8xzsskqbl5z315ipfmi8s2m"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; Test system must be loaded before, otherwise tests fail with:
+ ;; Component QURI-ASD::QURI-TEST not found, required by #<SYSTEM
+ ;; "quri">.
+ '(#:asd-systems '("quri-test"
+ "quri")))
+ (native-inputs `(("sbcl-prove" ,sbcl-prove)))
+ (inputs `(("sbcl-babel" ,sbcl-babel)
+ ("sbcl-split-sequence" ,sbcl-split-sequence)
+ ("sbcl-cl-utilities" ,sbcl-cl-utilities)
+ ("sbcl-alexandria" ,sbcl-alexandria)))
+ (home-page "https://github.com/fukamachi/quri")
+ (synopsis "Yet another URI library for Common Lisp")
+ (description
+ "QURI (pronounced \"Q-ree\") is yet another URI library for Common
Lisp. It is intended to be a replacement of PURI.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public cl-quri
(sbcl-package->cl-source-package sbcl-quri))