summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-24 11:32:29 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-24 11:32:29 +0200
commit5bc131ca7a686b1c1081372f447344b1d6c620b4 (patch)
tree91cbd4d593cfbde3b36135c96364accbba7a3f44 /gnu/packages/lisp-xyz.scm
parentc5a80784e2a08f676e2f49cbdab1f81db8d7dbb6 (diff)
downloadguix-patches-5bc131ca7a686b1c1081372f447344b1d6c620b4.tar
guix-patches-5bc131ca7a686b1c1081372f447344b1d6c620b4.tar.gz
gnu: Add ndebug.
* gnu/packages/lisp-xyz.scm (cl-ndebug, ecl-ndebug, sbcl-ndebug): New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c0df8b9c86..51d74bd8af 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22830,3 +22830,41 @@ It has extensive support for Guix, among others:
(inputs
(cons (list "osicat" cl-osicat)
(package-inputs pkg))))))
+
+(define-public sbcl-ndebug
+ (package
+ (name "sbcl-ndebug")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atlas-engineer/ndebug")
+ (commit version)))
+ (file-name (git-file-name "ndebug" version))
+ (sha256
+ (base32 "0wdp0wqk6clq3hh9yqmgdm55x50b5m7ly9004j2c8k5zz1rgi4rr"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list
+ sbcl-dissect
+ sbcl-lparallel
+ sbcl-slime-swank
+ sbcl-trivial-custom-debugger))
+ (native-inputs
+ (list sbcl-lisp-unit2))
+ (home-page "https://github.com/atlas-engineer/ndebug/")
+ (synopsis "Toolkit to build UI-aware Common Lisp debugger hooks")
+ (description
+ "NDebug provides a small set of utilities to make graphical (or, rather
+non-REPL-resident) Common Lisp applications easier to integrate with the
+standard Lisp debugger (@code{*debugger-hook*}, namely) and
+implementation-specific debugger hooks (via @code{trivial-custom-debugger}),
+especially in a multi-threaded context.")
+ (license license:bsd-3)))
+
+(define-public cl-ndebug
+ (sbcl-package->cl-source-package sbcl-ndebug))
+
+(define-public ecl-ndebug
+ (sbcl-package->ecl-package sbcl-ndebug))