summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-05 14:44:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-06-05 14:46:03 +0200
commit4e21f5bcabafc4e1f3375f5f91059bed67b5a8e3 (patch)
treeaabd57f9aac4e0196cf5c297c22c1fa3b8e94005 /gnu/packages/lisp-xyz.scm
parent4c7c3077904cb7ce790bee4b463133b02133f335 (diff)
downloadguix-patches-4e21f5bcabafc4e1f3375f5f91059bed67b5a8e3.tar
guix-patches-4e21f5bcabafc4e1f3375f5f91059bed67b5a8e3.tar.gz
gnu: Add cl-prometheus.collectors.sbcl.
* gnu/packages/lisp-xyz.scm (sbcl-prometheus.collectors.sbcl, cl-prometheus.collectors.sbcl): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cfc699d0d0..ceab76990d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11621,3 +11621,14 @@ Streams in ICDE’05.")
(define-public ecl-prometheus
(sbcl-package->ecl-package sbcl-prometheus))
+
+(define-public sbcl-prometheus.collectors.sbcl
+ (package
+ (inherit sbcl-prometheus)
+ (name "sbcl-prometheus.collectors.sbcl")
+ (inputs `(("prometheus" ,sbcl-prometheus)))
+ (synopsis "Prometheus collector for SBCL metrics")
+ (description "Prometheus collector for SBCL metrics.")))
+
+(define-public cl-prometheus.collectors.sbcl
+ (sbcl-package->cl-source-package sbcl-prometheus.collectors.sbcl))