summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-01 18:20:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-08-03 16:45:53 +0200
commit4b7cca1b45824f425908831c272496f5e040ba33 (patch)
treee772df8c01a88779e3097efec94fe11b5536be28 /gnu/packages/lisp-xyz.scm
parent6181f1f26310146ae509af2074c55f87e8f21a96 (diff)
downloadguix-patches-4b7cca1b45824f425908831c272496f5e040ba33.tar
guix-patches-4b7cca1b45824f425908831c272496f5e040ba33.tar.gz
gnu: sbcl-cl-gamepad: Remove asdf:compile-system workaround.
* gnu/packages/lisp-xyz.scm (sbcl-cl-gamepad)[arguments]: Remove 'build phase patch now that asdf-build-system/sbcl builds using asdf:load-system which fixes the bug. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 2 insertions, 30 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c57796a419..c34dfdf5a6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2018, 2020, 2021 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2020, 2021, 2022 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
@@ -18072,35 +18072,7 @@ tested (as shown in the examples).")
(substitute* "evdev-cffi.lisp"
(("libevdev.so" all)
(string-append (assoc-ref inputs "libevdev")
- "/lib/" all)))))
- ;; Here we use a custom build phase to work around a compilation bug.
- ;; Using 'asdf:compile-system' fails, but using 'asdf:load-system'
- ;; succeeds (and also compiles the system).
- ;; See https://github.com/Shirakumo/cl-gamepad/issues/8
- (replace 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (source-path (string-append out
- "/share/common-lisp/"
- (%lisp-type)))
- (translations `((,source-path
- :**/ :*.*.*)
- (,(string-append out
- "/lib/common-lisp/"
- (%lisp-type))
- :**/ :*.*.*))))
- (setenv "ASDF_OUTPUT_TRANSLATIONS"
- (format #f "~S" `(:output-translations
- ,translations
- :inherit-configuration)))
- (setenv "HOME" (assoc-ref outputs "out"))
- (with-directory-excursion (string-append source-path
- "/cl-gamepad")
- (invoke (%lisp-type)
- "--eval" "(require :asdf)"
- "--eval" "(asdf:load-asd (truename \"cl-gamepad.asd\"))"
- "--eval" "(asdf:load-system :cl-gamepad)"
- "--eval" "(quit)"))))))))
+ "/lib/" all))))))))
(inputs
`(("cffi" ,sbcl-cffi)
("documentation-utils" ,sbcl-documentation-utils)