summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 16:53:09 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 17:14:08 +0200
commit106354eaa42ceb83cf1eff66aee220531452a5c4 (patch)
tree974e47e236e70ff90b0e960eaaec44a23e38fe4a /gnu/packages/lisp-xyz.scm
parentba1727b0410326d4cd90eb7236d5539abaff8c67 (diff)
downloadguix-patches-106354eaa42ceb83cf1eff66aee220531452a5c4.tar
guix-patches-106354eaa42ceb83cf1eff66aee220531452a5c4.tar.gz
gnu: Add sbcl-clump-binary-tree.
* gnu/packages/lisp-xyz.scm (sbcl-clump-binary-tree): New variable.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index eed2026b72..cf5e763c78 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12010,3 +12010,12 @@ the concrete representation is exposed, but also high level interfaces
where the trees can be used as search trees or as trees that represent
sequences of objects.")
(license license:bsd-2))))
+
+(define-public sbcl-clump-binary-tree
+ (package
+ (inherit sbcl-clump-2-3-tree)
+ (name "sbcl-clump-binary-tree")
+ (arguments
+ '(#:asd-file "Binary-tree/clump-binary-tree.asd"
+ #:asd-system-name "clump-binary-tree"))
+ (synopsis "Implementation of binary trees for Common Lisp")))