summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-07-20 00:12:27 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-08-16 21:25:20 +0200
commit0193f9dd0304b90b4dfaebc0eb775187258e6fab (patch)
treea3283b3407d7ad3ff9538ad42010a1357c318ca6 /gnu/packages/lisp-xyz.scm
parentf41d75b75cc6bc11c21a6240c288e63ad6fe2dbd (diff)
downloadguix-patches-0193f9dd0304b90b4dfaebc0eb775187258e6fab.tar
guix-patches-0193f9dd0304b90b4dfaebc0eb775187258e6fab.tar.gz
gnu: Add cl-string-pokemonize.
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 03e474831d..cdd4d479ac 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22665,6 +22665,38 @@ the Processing language and shares some of the API.")
(define-public ecl-sketch
(sbcl-package->ecl-package sbcl-sketch))
+(define-public sbcl-string-pokemonize
+ (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+ (revision "0"))
+ (package
+ (name "sbcl-string-pokemonize")
+ (version (git-version "20210503" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoe/string-pokemonize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:asd-systems '("string-pokemonize")))
+ (synopsis "Alternate upper- and lowercase")
+ (description
+ "@code{string-pokemonize} provides a function that alternates uppercase
+and lowercase characters for a given string.")
+ (home-page "https://github.com/phoe/string-pokemonize")
+ (license license:expat))))
+
+(define-public cl-string-pokemonize
+ (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+ (sbcl-package->ecl-package sbcl-string-pokemonize))
+
(define-public sbcl-binary-types
(let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
(package