summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-07-01 11:18:42 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-07-01 11:19:53 +0200
commit012bdf2e6108d50fd7c27644823fe26c73eb5ed3 (patch)
tree37475dc552dcc768ac873664df2c72747f73134a /gnu/packages/lisp-xyz.scm
parentd2a34ebae0da82d0048307868fff11f899ec7a29 (diff)
downloadguix-patches-012bdf2e6108d50fd7c27644823fe26c73eb5ed3.tar
guix-patches-012bdf2e6108d50fd7c27644823fe26c73eb5ed3.tar.gz
gnu: sbcl-alexandria: Update to 1.1.
* gnu/packages/lisp-xyz.scm (sbcl-alexandria): Update to 1.1.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f5ec0f799e..97b5ec71e9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -74,30 +74,29 @@
#:use-module (srfi srfi-19))
(define-public sbcl-alexandria
- (let ((commit "5e5c7d83090cc0fbf32c4628362ac3ce2c50dc59"))
- (package
- (name "sbcl-alexandria")
- (version "1.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.common-lisp.net/alexandria/alexandria.git")
- (commit commit)))
- (sha256
- (base32
- "010w8829dq28jf8ajfzas9nfvpxa5bal04mg299xq6y9spihc2iz"))
- (file-name (git-file-name name version))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("rt" ,sbcl-rt)))
- (synopsis "Collection of portable utilities for Common Lisp")
- (description
- "Alexandria is a collection of portable utilities. It does not contain
+ (package
+ (name "sbcl-alexandria")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.common-lisp.net/alexandria/alexandria.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1zanb3xa98js0i66iqcmx3gp123p1m2d1fxn8d7bfzyfad5f6xn2"))
+ (file-name (git-file-name name version))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("rt" ,sbcl-rt)))
+ (synopsis "Collection of portable utilities for Common Lisp")
+ (description
+ "Alexandria is a collection of portable utilities. It does not contain
conceptual extensions to Common Lisp. It is conservative in scope, and
portable between implementations.")
- (home-page "https://common-lisp.net/project/alexandria/")
- (license license:public-domain))))
+ (home-page "https://common-lisp.net/project/alexandria/")
+ (license license:public-domain)))
(define-public cl-alexandria
(sbcl-package->cl-source-package sbcl-alexandria))