summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-01 20:41:37 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-08-03 16:45:53 +0200
commite2562197fb2db4fdadfbe1c9d904a444d78e14e1 (patch)
tree1792730fa123c5bf4e90490f3baef812971cad61 /gnu/packages/lisp-check.scm
parent4b7cca1b45824f425908831c272496f5e040ba33 (diff)
downloadguix-patches-e2562197fb2db4fdadfbe1c9d904a444d78e14e1.tar
guix-patches-e2562197fb2db4fdadfbe1c9d904a444d78e14e1.tar.gz
gnu: Remove obsolete references to asd-files and test-asd-file.
In a previous commit we've update the build system to let ASDF locate the .asd files for us, so package definition no longer need to provide this information. * gnu/packages/lisp-check.scm: Do it. * gnu/packages/lisp-xyz.scm: Do it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 39f7d8ca61..8c850ee850 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018, 2019, 2020, 2021 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2019, 2020, 2021, 2022 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
@@ -116,8 +116,7 @@ designed to embed randomized tests in whatever framework you like.")
;; Error while trying to load definition for system checkl-test from
;; pathname [...]/checkl-test.asd: The function CHECKL:DEFINE-TEST-OP
;; is undefined.
- '(#:asd-files '("checkl.asd")
- #:tests? #f))
+ '(#:tests? #f))
(native-inputs
(list sbcl-fiveam))
(inputs
@@ -881,8 +880,7 @@ interactive development.")
sbcl-mgl-pax
sbcl-trivial-gray-streams))
(arguments
- `(#:asd-files '("try.asdf.asd" "try.asd")
- ;; FIXME: Get tests to work
+ `(;; FIXME: Get tests to work
#:tests? #f))
(home-page "https://github.com/melisgl/try")
(synopsis "Common Lisp test framework")