summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-06-04 20:26:48 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-24 14:22:09 +0200
commit8a40a964e01ba07bf0c6ecdd90c5d064a697f9d6 (patch)
treeca8012ca04ac66aa919dcd0c96f4142ddc2991df /gnu/packages/lisp-check.scm
parente101a117eb5af9affcf68e27e91d68d3bfd72986 (diff)
downloadguix-patches-8a40a964e01ba07bf0c6ecdd90c5d064a697f9d6.tar
guix-patches-8a40a964e01ba07bf0c6ecdd90c5d064a697f9d6.tar.gz
gnu: Add cl-nst.
Initiate new lisp-check module the same way as other language specific ones (python-check, haskell-check). * gnu/local.mk (GNU_SYSTEM_MODULES): Add lisp-check.scm. * gnu/packages/lisp-check.scm (sbcl-nst, ecl-nst, cl-nst): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
new file mode 100644
index 0000000000..95918433c4
--- /dev/null
+++ b/gnu/packages/lisp-check.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lisp-check)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages lisp-xyz)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system asdf))
+
+;;; Commentary:
+;;;
+;;; This module only contains Common Lisp libraries related to code testing
+;;; facilities.
+
+(define-public sbcl-nst
+ (let ((commit "6c0990f594abcf5887e8d80f1035e3b60454b61b")
+ (revision "1"))
+ (package
+ (name "sbcl-nst")
+ (version (git-version "4.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jphmrst/cl-nst")
+ (commit commit)))
+ (file-name (git-file-name "nst" version))
+ (sha256
+ (base32 "1hf3r6pqbnd9vsd1i24qmz928kia72hdgmiafiwb6jw1hmj3r6ga"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("closer-mop" ,sbcl-closer-mop)
+ ("org-sampler" ,sbcl-org-sampler)))
+ (home-page "https://github.com/jphmrst/cl-nst")
+ (synopsis "Unit testing for Common Lisp")
+ (description
+ "NST is a unit/regression testing system for Common Lisp.")
+ (license license:llgpl))))
+
+(define-public ecl-nst
+ (sbcl-package->ecl-package sbcl-nst))
+
+(define-public cl-nst
+ (sbcl-package->cl-source-package sbcl-nst))
+
+;;; lisp-check.scm ends here