summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorCharles Jackson <charles.b.jackson@protonmail.com>2021-10-21 11:23:53 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-21 11:25:29 +0200
commit49347291efde17edb307eefaabd77f37b0ff8bc2 (patch)
tree5f0e7dc04438418abead9cf0c35bad76532c7de6 /gnu/packages/lisp-check.scm
parentc0d672853a005fc625169f5c905d4562b9b33635 (diff)
downloadguix-patches-49347291efde17edb307eefaabd77f37b0ff8bc2.tar
guix-patches-49347291efde17edb307eefaabd77f37b0ff8bc2.tar.gz
gnu: Add cl-should-test.
* gnu/packages/lisp-check.scm (cl-should-test, ecl-should-test, sbcl-should-test): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm45
1 files changed, 39 insertions, 6 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 95918433c4..6a8dccf8bb 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -1,5 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16,6 +18,9 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+;;; This module only contains Common Lisp libraries related to code testing
+;;; facilities.
+
(define-module (gnu packages lisp-check)
#:use-module (gnu packages)
#:use-module ((guix licenses) #:prefix license:)
@@ -24,11 +29,6 @@
#:use-module (guix git-download)
#:use-module (guix build-system asdf))
-;;; Commentary:
-;;;
-;;; This module only contains Common Lisp libraries related to code testing
-;;; facilities.
-
(define-public sbcl-nst
(let ((commit "6c0990f594abcf5887e8d80f1035e3b60454b61b")
(revision "1"))
@@ -60,4 +60,37 @@
(define-public cl-nst
(sbcl-package->cl-source-package sbcl-nst))
-;;; lisp-check.scm ends here
+(define-public sbcl-should-test
+ (let ((commit "48facb9f9c07aeceb71fc0c48ce17fd7d54a09d4")
+ (revision "0"))
+ (package
+ (name "sbcl-should-test")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vseloved/should-test")
+ (commit commit)))
+ (file-name (git-file-name "should-test" version))
+ (sha256
+ (base32 "1fqqa7lhf28qg60ji9libkylkcy747x576qpjn1y7c945j2fxmnm"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("local-time" ,sbcl-local-time)
+ ("osicat" ,sbcl-osicat)
+ ("rutils" ,sbcl-rutils)))
+ (home-page "https://github.com/vseloved/should-test")
+ (synopsis "Minimal yet feature-rich Common Lisp test framework")
+ (description
+ "SHOULD-TEST is a methodology-agnostic and non-opinionated Common Lisp
+test framework, i.e. it doesn't care what kind of test approach you'd like to
+take.")
+ (license license:expat))))
+
+(define-public cl-should-test
+ (sbcl-package->cl-source-package sbcl-should-test))
+
+(define-public ecl-should-test
+ (sbcl-package->ecl-package sbcl-should-test))