summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-11-07 19:40:06 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-08 09:25:25 +0100
commit07a68587b0e00a7b7c231d1360bbc5fb47fc51bf (patch)
tree1c3774545931882e3d8e0bb11fcabd3f934c41c5 /gnu/packages/lisp-check.scm
parent6ec0c6c7678234ff5ab4c892903e0b682cbd876d (diff)
downloadguix-patches-07a68587b0e00a7b7c231d1360bbc5fb47fc51bf.tar
guix-patches-07a68587b0e00a7b7c231d1360bbc5fb47fc51bf.tar.gz
gnu: Add cl-kaputt.
* gnu/packages/lisp-check.scm: (sbcl-kaputt, cl-kaputt, ecl-kaputt): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index ca00e5054e..dda0705e60 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -396,6 +396,47 @@ with a focus on interactive development.")
(define-public ecl-hu.dwim.stefil
(sbcl-package->ecl-package sbcl-hu.dwim.stefil))
+(define-public sbcl-kaputt
+ (let ((commit "f26c9b0f8219fe61d86249198ef85174eecafc10")
+ (revision "1"))
+ (package
+ (name "sbcl-kaputt")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/foretspaisibles/cl-kaputt")
+ (commit commit)))
+ (file-name (git-file-name "kaputt" version))
+ (sha256
+ (base32 "10a78032vnf12kjjpfmq9ign38cad237ycyq37dwnx922nxjjaj4"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)))
+ (home-page "https://github.com/foretspaisibles/cl-kaputt")
+ (synopsis "Simple interactive test framework for Common Lisp")
+ (description
+ "KAPUTT is a test framework for Common Lisp that focuses on the
+following features:
+
+@itemize
+@item KAPUTT is simple, it only defines three abstractions testcase, assertion
+and protocol and does not add any artefact on the backtrace when errors occur.
+
+@item KAPUTT is extensible, it is possible to add problem-specific assertions
+to make test code more informative.
+
+@item KAPUTT fits well interactive development.
+@end itemize\n")
+ (license license:cecill-b))))
+
+(define-public ecl-kaputt
+ (sbcl-package->ecl-package sbcl-kaputt))
+
+(define-public cl-kaputt
+ (sbcl-package->cl-source-package sbcl-kaputt))
+
(define-public sbcl-lift
(let ((commit "2594160d6ca3a77d8750110dfa63214256aab852")
(revision "2"))