summaryrefslogtreecommitdiff
path: root/gnu/packages/lirc.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-19 17:41:22 -0400
committerLeo Famulari <leo@famulari.name>2016-08-19 17:45:05 -0400
commit5dee9186b4090422d7eefae2d5028413e5335891 (patch)
treec455fa80f1f98c007b18acb0526a7f6fdd366715 /gnu/packages/lirc.scm
parent21085261588fb143d1ac2a46827758cc972d35ff (diff)
downloadguix-patches-5dee9186b4090422d7eefae2d5028413e5335891.tar
guix-patches-5dee9186b4090422d7eefae2d5028413e5335891.tar.gz
gnu: python-lirc: Fix file-name.
* gnu/packages/lirc.scm (python-lirc, python2-lirc): Indentation fixes. [source]: Fix misleading file-name.
Diffstat (limited to 'gnu/packages/lirc.scm')
-rw-r--r--gnu/packages/lirc.scm88
1 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/lirc.scm b/gnu/packages/lirc.scm
index 4c45c0ecb0..b8fbeb61ba 100644
--- a/gnu/packages/lirc.scm
+++ b/gnu/packages/lirc.scm
@@ -89,50 +89,50 @@ on just one button press.")
(license license:gpl2+)))
(define-public python-lirc
- (let ((commit "4091fe918f3eed2513dad008828565cace408d2f")
- (revision "1"))
- (package
- (name "python-lirc")
- (version (string-append "1.2.1-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tompreston/python-lirc.git")
- (commit commit)))
- (sha256
- (base32
- "0cm47s5pvijfs3v2k7hmpxv3mvp4n5la0ihnsczk5ym3iq166jil"))
- (file-name (string-append name "-" version ".tar.gz"))))
- (build-system python-build-system)
- (inputs
- `(("lirc" ,lirc)))
- (native-inputs
- `(("python-cython" ,python-cython)))
- (arguments
- `(#:tests? #f ; the only tests that exist are human-interactive
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'build-from-cython-files
- (lambda _
- (zero? (system* "make" "py3")))))))
- (home-page "https://github.com/tompreston/python-lirc")
- (synopsis "Python bindings for LIRC")
- (description "@code{lirc} is a Python module which provides LIRC bindings.")
- (license license:gpl3)
- (properties `((python2-variant . ,(delay python2-lirc)))))))
-
-(define-public python2-lirc
- (let ((base (package-with-python2 (strip-python2-variant python-lirc))))
+ (let ((commit "4091fe918f3eed2513dad008828565cace408d2f")
+ (revision "1"))
(package
- (inherit base)
+ (name "python-lirc")
+ (version (string-append "1.2.1-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tompreston/python-lirc.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0cm47s5pvijfs3v2k7hmpxv3mvp4n5la0ihnsczk5ym3iq166jil"))
+ (file-name (string-append name "-" version))))
+ (build-system python-build-system)
+ (inputs
+ `(("lirc" ,lirc)))
+ (native-inputs
+ `(("python-cython" ,python-cython)))
(arguments
- `(#:tests? #f ; the only tests there are are human-interactive
+ `(#:tests? #f ; the only tests that exist are human-interactive
#:phases
- (modify-phases %standard-phases
- (add-before 'build 'build-from-cython-files
- (lambda _
- (zero? (system* "make" "py2")))))))
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ("python2-cython" ,python2-cython))))))
+ (modify-phases %standard-phases
+ (add-before 'build 'build-from-cython-files
+ (lambda _
+ (zero? (system* "make" "py3")))))))
+ (home-page "https://github.com/tompreston/python-lirc")
+ (synopsis "Python bindings for LIRC")
+ (description "@code{lirc} is a Python module which provides LIRC bindings.")
+ (license license:gpl3)
+ (properties `((python2-variant . ,(delay python2-lirc)))))))
+
+ (define-public python2-lirc
+ (let ((base (package-with-python2 (strip-python2-variant python-lirc))))
+ (package
+ (inherit base)
+ (arguments
+ `(#:tests? #f ; the only tests that exist are human-interactive
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'build-from-cython-files
+ (lambda _
+ (zero? (system* "make" "py2")))))))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ("python2-cython" ,python2-cython))))))