summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2021-12-13 23:34:29 +0300
committerLudovic Courtès <ludo@gnu.org>2022-03-09 23:38:18 +0100
commitfcebc4aa12300544a2d62eab5ed06d1cb9eeed43 (patch)
tree1b8039d24ca22bd8f72d5a94022792b15df0abfe /gnu/packages/linux.scm
parenteeac33a3defec89fcc5d417844fd4ce67b41ba0e (diff)
downloadguix-patches-fcebc4aa12300544a2d62eab5ed06d1cb9eeed43.tar
guix-patches-fcebc4aa12300544a2d62eab5ed06d1cb9eeed43.tar.gz
gnu: Add libtree.
* gnu/packages/linux.scm (libtree): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a42a8bebda..cc0084be8a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -60,6 +60,8 @@
;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8800,3 +8802,33 @@ older system-wide @file{/sys} interface.")
(license (list license:lgpl2.1+ ;; libgpiod
license:gpl2+ ;; gpio-tools
license:lgpl3+)))) ;; C++ bindings
+
+(define-public libtree
+ (package
+ (name "libtree")
+ (version "3.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/haampie/libtree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "072624anz9g01mp5vfkahfmzy0nb7axg5rwk3n1yrdm4hr3d4zrb"))))
+ (arguments
+ (list #:make-flags
+ ;; NOTE: Official documentation recommends to build libtree with
+ ;; "-static" flag.
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/haampie/libtree")
+ (synopsis "Show output of @command{ldd} as a tree")
+ (description
+ "This tool turns @command{ldd} into a tree and explains how shared
+libraries are found or why they cannot be located.")
+ (license license:expat)))