summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:18:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:18:23 +0100
commitf77ab2abdfd55a38fcbb0e8ebcc4871ab4986bdc (patch)
treed0220669bf48d7082a9ddbe0f8005eb966033e7a /gnu/packages/linux.scm
parent961d2ee2695b38503b463d055e9c7edbcc0bf307 (diff)
downloadguix-patches-f77ab2abdfd55a38fcbb0e8ebcc4871ab4986bdc.tar
guix-patches-f77ab2abdfd55a38fcbb0e8ebcc4871ab4986bdc.tar.gz
gnu: bluez: Incorporate grafted changes.
* gnu/packages/linux.scm (bluez)[replacement]: Remove. [source](patches): New field. (bluez/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index acfee1ac02..04788d2f8a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4079,13 +4079,13 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(define-public bluez
(package
(name "bluez")
- (replacement bluez/fixed)
(version "5.53")
(source (origin
(method url-fetch)
(uri (string-append
"mirror://kernel.org/linux/bluetooth/bluez-"
version ".tar.xz"))
+ (patches (search-patches "bluez-CVE-2020-0556.patch"))
(sha256
(base32
"1g1qg6dz6hl3csrmz75ixr12lwv836hq3ckb259svvrg62l2vaiq"))))
@@ -4145,14 +4145,6 @@ Bluetooth audio output devices like headphones or loudspeakers.")
is flexible, efficient and uses a modular implementation.")
(license license:gpl2+)))
-(define bluez/fixed
- (package
- (inherit bluez)
- (source (origin
- (inherit (package-source bluez))
- (patches (append (origin-patches (package-source bluez))
- (search-patches "bluez-CVE-2020-0556.patch")))))))
-
(define-public fuse-exfat
(package
(name "fuse-exfat")