summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-24 17:16:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:36 +0100
commitf69a22accfe95860f04186ba6fcd997c19d381f5 (patch)
treebdd1f4e6093ead9eb44c67e9b86da0a5696308ca /gnu/packages/linux.scm
parent0830b2f4aaed3630ba266a7bcc92083ff04d5bed (diff)
downloadguix-patches-f69a22accfe95860f04186ba6fcd997c19d381f5.tar
guix-patches-f69a22accfe95860f04186ba6fcd997c19d381f5.tar.gz
gnu: util-linux: Update to 2.35.
* gnu/packages/linux.scm (util-linux): Update to 2.35. [arguments]: Add substitution to fix test locale.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3be93e77dc..569ba34aa4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1096,7 +1096,7 @@ providing the system administrator with some help in common tasks.")
(define-public util-linux
(package
(name "util-linux")
- (version "2.34")
+ (version "2.35")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/"
@@ -1104,7 +1104,7 @@ providing the system administrator with some help in common tasks.")
"util-linux-" version ".tar.xz"))
(sha256
(base32
- "1db2kydkwjmvgd1glkcba3adhidxw0f1x735dcjdpdjjf869sgvl"))
+ "1jg2vywxi9m2h0f2pz0a7a9afvv1j5726dg0cwryrhb809b1n25k"))
(patches (search-patches "util-linux-tests.patch"))
(modules '((guix build utils)))
(snippet
@@ -1160,6 +1160,10 @@ providing the system administrator with some help in common tasks.")
(substitute* "tests/ts/misc/mcookie"
(("/etc/services")
(string-append net "/etc/services")))
+
+ ;; The C.UTF-8 locale does not exist in our libc.
+ (substitute* "tests/ts/column/invalid-multibyte"
+ (("C\\.UTF-8") "en_US.utf8"))
#t)))
(add-after 'install 'move-static-libraries
(lambda* (#:key outputs #:allow-other-keys)