summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorAnders Thuné <asse.97@gmail.com>2020-07-14 10:18:51 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-27 12:06:36 +0200
commitd888a9c9f9dec9fefb4181d169061641963ce311 (patch)
treed757e0ed151669ddeb5fcf70076c8ce555826219 /gnu/packages/linux.scm
parent73cb3e103f35356b83cb091f15c536c21bf53981 (diff)
downloadguix-patches-d888a9c9f9dec9fefb4181d169061641963ce311.tar
guix-patches-d888a9c9f9dec9fefb4181d169061641963ce311.tar.gz
gnu: Add pipewire-0.3.
* gnu/packages/linux.scm (pipewire-0.3): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c98aa9bcf..cf5f02df26 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -125,6 +126,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages web)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
@@ -7115,6 +7117,34 @@ and Flatpak we expect PipeWire to provide a core building block for the future
of Linux application development.")
(license license:lgpl2.0+)))
+(define-public pipewire-0.3
+ (package
+ (inherit pipewire)
+ (name "pipewire")
+ (version "0.3.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PipeWire/pipewire")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g149vyaigf4gzm764fcgxxci9niw19z0af9afs4diwq5xzr1qd3"))))
+ (arguments
+ '(#:configure-flags '("-Dsystemd=false")
+ #:phases
+ (modify-phases %standard-phases
+ ;; Skip shrink-runpath, otherwise validate-runpath fails
+ (delete 'shrink-runpath))))
+ (inputs
+ (append (package-inputs pipewire)
+ `(("bluez" ,bluez)
+ ("jack" ,jack-2)
+ ("pulseaudio" ,pulseaudio)
+ ("vulkan-loader" ,vulkan-loader)
+ ("vulkan-headers" ,vulkan-headers))))))
+
(define-public ell
(package
(name "ell")