summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2020-08-08 23:09:53 -0400
committerMark H Weaver <mhw@netris.org>2020-08-08 23:25:56 -0400
commitcb97d076491495aa956dbff93679a51cc5708010 (patch)
tree421a92e72d1eff1194dd8deccc4826889d798b28 /gnu/packages/linux.scm
parent8e6344a5fb22e2614dcb0db8e24658e63c6121c7 (diff)
downloadguix-patches-cb97d076491495aa956dbff93679a51cc5708010.tar
guix-patches-cb97d076491495aa956dbff93679a51cc5708010.tar.gz
gnu: Add linux-libre@5.8 source and headers.
Note that this commit adds only the deblobbed source and headers. The kernel packages for 5.8 will be provided in later commit(s). * gnu/packages/linux.scm (deblob-scripts-5.8, linux-libre-5.8-version) (linux-libre-5.8-pristine-source, linux-libre-5.8-source) (linux-libre-headers-5.8): New variables.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b18bb3a3c4..2f83801dc2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -202,6 +202,12 @@ defconfig. Return the appropriate make target if applicable, otherwise return
"deblob-check"))
(sha256 deblob-check-hash))))
+(define deblob-scripts-5.8
+ (linux-libre-deblob-scripts
+ "5.8"
+ (base32 "07z7sglyrfh0706icqqf3shadf638pvyid9386r661ds5lbsa2mw")
+ (base32 "1nzf1wzva52bm41j2ba0m1vr0cpfwnybdwv5ff6km49l0gziaqx7")))
+
(define deblob-scripts-5.7
(linux-libre-deblob-scripts
"5.7.14"
@@ -379,6 +385,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256 hash)))
+(define-public linux-libre-5.8-version "5.8")
+(define-public linux-libre-5.8-pristine-source
+ (let ((version linux-libre-5.8-version)
+ (hash (base32 "1xgibkwb1yfl6qdlbxyagai0qc1pk5ark7giz1512hh6ma353xz7")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.8)))
+
(define-public linux-libre-5.7-version "5.7.14")
(define-public linux-libre-5.7-pristine-source
(let ((version linux-libre-5.7-version)
@@ -455,6 +469,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.8-source
+ (source-with-patches linux-libre-5.8-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.7-source
(source-with-patches linux-libre-5.7-pristine-source
(list %boot-logo-patch
@@ -559,6 +578,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.8
+ (make-linux-libre-headers* linux-libre-5.8-version
+ linux-libre-5.8-source))
+
(define-public linux-libre-headers-5.7
(make-linux-libre-headers* linux-libre-5.7-version
linux-libre-5.7-source))