summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-14 22:37:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 23:50:24 +0100
commitc148d2ebd45cdf11da31328265bd2e14dcd5f91a (patch)
tree8ae66263b7151c46851c9a5bb020d9e7b3fdcff8 /gnu/packages/linux.scm
parent1385e86c259bcd7a8c86b656aa13518c1e544506 (diff)
downloadguix-patches-c148d2ebd45cdf11da31328265bd2e14dcd5f91a.tar
guix-patches-c148d2ebd45cdf11da31328265bd2e14dcd5f91a.tar.gz
gnu: xfsprogs: Move util-linux to inputs.
* gnu/packages/linux.scm (xfsprogs)[native-inputs]: Move UTIL-LINUX ... [inputs]: ... here. Rename key to "libuuid" for clarity.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5535ddf86e..bb1f20c3dc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5974,10 +5974,10 @@ IP addresses and routes, and configure IPsec.")
(lambda _
(invoke "make" "install-dev"))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("util-linux" ,util-linux)))
+ `(("gettext" ,gettext-minimal)))
(inputs
- `(("python" ,python-wrapper)))
+ `(("libuuid" ,util-linux)
+ ("python" ,python-wrapper)))
(home-page "https://xfs.wiki.kernel.org/")
(synopsis "XFS file system tools")
(description "This package provides commands to create and check XFS