summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-08-02 14:22:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-08-18 00:36:28 +0200
commitae5947b0ef20eaba7066dfd6ceeb9eed982e72c3 (patch)
treead99d2460f60e789228741bec07db6ea94a343fe /gnu/packages/linux.scm
parent3eb7c000385b929583ced9c4adb9ce796512705e (diff)
downloadguix-patches-ae5947b0ef20eaba7066dfd6ceeb9eed982e72c3.tar
guix-patches-ae5947b0ef20eaba7066dfd6ceeb9eed982e72c3.tar.gz
gnu: Add libfabric.
* gnu/packages/linux.scm (libfabric): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7aa04bc3e4..52637f1332 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4306,3 +4306,34 @@ tool, to understand the type of environment a process runs in, and for
comparing system environments.")
(home-page "http://github.com/jamesodhunt/procenv/")
(license license:gpl3+)))
+
+(define-public libfabric
+ (package
+ (name "libfabric")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/ofiwg/libfabric/releases/download/v"
+ version "/libfabric-" version ".tar.bz2"))
+ (sha256
+ (base32 "19l2m1frna1l765z4j7wl8hp4rb9wrh0hy5496685hd183hmy5pv"))))
+ (build-system gnu-build-system)
+ (inputs `(("rdma-core" ,rdma-core)
+ ;; TODO: add psm, psm(2).
+ ("libnl" ,libnl)))
+ (home-page "https://ofiwg.github.io/libfabric/")
+ (synopsis "Open Fabric Interfaces")
+ (description
+ "OpenFabrics Interfaces (OFI) is a framework focused on exporting fabric
+communication services to applications. OFI is best described as a collection
+of libraries and applications used to export fabric services. The key
+components of OFI are: application interfaces, provider libraries, kernel
+services, daemons, and test applications.
+
+Libfabric is a core component of OFI. It is the library that defines and
+exports the user-space API of OFI, and is typically the only software that
+applications deal with directly. It works in conjunction with provider
+libraries, which are often integrated directly into libfabric.")
+ (license (list license:bsd-2 license:gpl2)))) ;dual