summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-21 13:08:25 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-21 15:17:22 +0100
commit93a267b7a40a762a66fa5149336f2c5545cbed30 (patch)
tree087fc6745c266e055be8d716207b5a588545eb16 /gnu/packages/linux.scm
parent2eb39cd26c58b6ccca38ea9f7514207fe04eb1fd (diff)
downloadguix-patches-93a267b7a40a762a66fa5149336f2c5545cbed30.tar
guix-patches-93a267b7a40a762a66fa5149336f2c5545cbed30.tar.gz
gnu: blktrace: Update to db4f634.
* gnu/packages/linux.scm (blktrace): Update to db4f634. [revision]: Increment variable. [patches]: Remove variable. * gnu/packages/patches/blktrace-use-rmtree.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 12da3c8f63..a1973c1e60 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4014,8 +4014,8 @@ applications.")
(define-public blktrace
;; Take a newer commit to get the fix for CVE-2018-10689.
- (let ((commit "f4f8ef7cdea138cfaa2f3ca0ee31fa23d3bcf1cc")
- (revision "0"))
+ (let ((commit "db4f6340e04716285ea56fe26d76381c3adabe58")
+ (revision "1"))
(package
(name "blktrace")
(version (git-version "1.2.0" revision commit))
@@ -4027,9 +4027,8 @@ applications.")
(url home-page)
(commit commit)))
(sha256
- (base32 "1ihdfimg7mfcgdm6l09xfqx5kdyv42x743dxp3z3w65q5vd7xy89"))
- (file-name (git-file-name name version))
- (patches (search-patches "blktrace-use-rmtree.patch"))))
+ (base32 "0ah7xn4qnx09k6bm39p69av7d0c8cl6863drv6a1nf914sq1kpgp"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
'(#:make-flags