summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-08-05 00:02:55 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-05 00:02:55 +0200
commit90ea83ee95ad467fc4a49f4c42d0df94d2952330 (patch)
tree3e07b2f9b55270d0b48c68e5cef6e573f3071153 /gnu/packages/linux.scm
parentc8737b1e41f7ef5c730fb0b47c5b478ab58b2341 (diff)
downloadguix-patches-90ea83ee95ad467fc4a49f4c42d0df94d2952330.tar
guix-patches-90ea83ee95ad467fc4a49f4c42d0df94d2952330.tar.gz
gnu: bluez: Work around test failure on ARM.
This aims to skip the segfaulting test at <https://hydra.gnu.org/build/2195551>. * gnu/packages/linux.scm (bluez)[arguments]: Add #:make-flags when (%current-system) is "armhf-linux".
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 915b4a203b..0ee0a5acd0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2975,7 +2975,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
"1sb4aflgyrl7apricjipa8wx95qm69yja0lmn2f19g560c3v1b2c"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
+ `(#:configure-flags
(let ((out (assoc-ref %outputs "out")))
(list "--sysconfdir=/etc"
"--localstatedir=/var"
@@ -3004,7 +3004,12 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(string-append out "/lib/udev/hid2hci --method"))
(("/sbin/udevadm")
(string-append (assoc-ref inputs "eudev") "/bin/udevadm")))
- #t))))))
+ #t))))
+
+ ;; FIXME: Skip one test that segfaults on ARM.
+ ,@(if (string=? (%current-system) "armhf-linux")
+ '(#:make-flags '("XFAIL_TESTS=unit/test-gatt"))
+ '())))
(native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)))