summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 01:01:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 01:13:38 +0100
commit8d8272dd474abebed4d98b9b14e525073c6dc436 (patch)
tree235fe17e5617cd42b01a6e4809def8998963125e /gnu/packages/linux.scm
parenta00543b4397c85eb1bc8142ed885aa3b50cf5ecb (diff)
downloadguix-patches-8d8272dd474abebed4d98b9b14e525073c6dc436.tar
guix-patches-8d8272dd474abebed4d98b9b14e525073c6dc436.tar.gz
gnu: iptables: Fix cross-compilation.
* gnu/packages/linux.scm (iptables)[arguments]: Rewrite as G-expression to avoid %OUTPUT when cross-compiling.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 57f6e7489c..f67dd85572 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2642,9 +2642,13 @@ external rate conversion.")
(inputs
(list libmnl libnftnl/fixed))
(arguments
- '(#:tests? #f ; no test suite
- #:configure-flags ; add $libdir to the RUNPATH of executables
- (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
+ (list #:tests? #f ; no test suite
+ #:configure-flags ; add $libdir to the RUNPATH of executables
+ ;; XXX TODO: Replace with simply #$OUTPUT on core-updates.
+ #~(list (string-append "LDFLAGS=-Wl,-rpath="
+ #$(if (%current-target-system)
+ #~#$output
+ #~%output) "/lib"))))
(home-page "https://www.netfilter.org/projects/iptables/index.html")
(synopsis "Programs to configure Linux IP packet filtering rules")
(description