summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-12 23:30:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-13 00:32:22 +0200
commit6a724b0277f31245a0573c8347a6462786d7c0d1 (patch)
treee2ce49d105cdfa3350d60428b7083700841b6474 /gnu/packages/linux.scm
parentf5d0e35b940ec3edc62f8493d9156fc9b88ba526 (diff)
downloadguix-patches-6a724b0277f31245a0573c8347a6462786d7c0d1.tar
guix-patches-6a724b0277f31245a0573c8347a6462786d7c0d1.tar.gz
gnu: btrfs-progs: Update to 5.12.
* gnu/packages/linux.scm (btrfs-progs): Update to 5.12. [native-inputs]: Add linux-libre-headers-5.10.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4be5e8e217..cb80774696 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5115,7 +5115,7 @@ and copy/paste text in the console and in xterm.")
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "5.11.1")
+ (version "5.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -5123,7 +5123,7 @@ and copy/paste text in the console and in xterm.")
"btrfs-progs-v" version ".tar.xz"))
(sha256
(base32
- "1zpbpmq8qndwls40yg2c9xj9ca6mcxdziadj5i8fbi3ffp2crap3"))))
+ "0mgdcqyww20fvh0js717yvla1hkky12c6dfhascicmrfw5fdcfcf"))))
(build-system gnu-build-system)
(outputs '("out"
"static")) ; static versions of the binaries in "out"
@@ -5168,6 +5168,9 @@ and copy/paste text in the console and in xterm.")
("asciidoc" ,asciidoc)
("python" ,python)
("xmlto" ,xmlto)
+ ;; Remove this input entirely when the default headers
+ ;; version provides blk_zone.capacity (>= 5.9).
+ ("linux-libre-headers" ,linux-libre-headers-5.10)
;; For building documentation.
("libxml2" ,libxml2)
("docbook-xsl" ,docbook-xsl)