summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-12-14 02:17:48 -0500
committerLeo Famulari <leo@famulari.name>2020-12-19 16:06:09 -0500
commit66b5bc319177f54a65085fbc39ee984d387a3329 (patch)
tree23a4dcdd06201d77df070f915e79e38ae14993b8 /gnu/packages/linux.scm
parent10c06966af07908aa15f79c3be1d6a64d7717d02 (diff)
downloadguix-patches-66b5bc319177f54a65085fbc39ee984d387a3329.tar
guix-patches-66b5bc319177f54a65085fbc39ee984d387a3329.tar.gz
gnu: linux-libre: Update to 5.10.1.
* gnu/packages/aux-files/linux-libre/5.10-arm.conf, gnu/packages/aux-files/linux-libre/5.10-arm64.conf, gnu/packages/aux-files/linux-libre/5.10-i686.conf, gnu/packages/aux-files/linux-libre/5.10-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. * gnu/packages/linux.scm (linux-libre-5.10-version, deblob-scripts-5.10, linux-libre-5.10-pristine-source, linux-libre-5.10-source, linux-libre-headers-5.10, linux-libre-5.10): New variables. (linux-libre-version, linux-libre-pristine-source, linux-libre-source, linux-libre, linux-libre-with-bpf): Update to 5.10.1.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm45
1 files changed, 36 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9cef07454c..d492faba18 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -349,9 +349,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
+;; The current "stable" kernels. That is, the most recently released major
+;; versions that are still supported upstream.
+(define-public linux-libre-5.10-version "5.10.1")
+(define deblob-scripts-5.10
+ (linux-libre-deblob-scripts
+ linux-libre-5.10-version
+ (base32 "0i99adbfjnir8p8ihhac58dv8p7mnqg4z2jpgvhj35lksdskngf7")
+ (base32 "0hh27ccqimagr3aij7ygwikxw66y63sqwd0xlf49bhpjd090r9a7")))
+(define-public linux-libre-5.10-pristine-source
+ (let ((version linux-libre-5.10-version)
+ (hash (base32 "0p2fl7kl4ckphq17xir7n7vgrzlhbdqmyd2yyp4yilwvih9625pd")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.10)))
-;; The current "stable" kernel. That is, the most recently released major
-;; version.
(define-public linux-libre-5.9-version "5.9.15")
(define deblob-scripts-5.9
(linux-libre-deblob-scripts
@@ -461,6 +473,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.10-source
+ (source-with-patches linux-libre-5.10-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.9-source
(source-with-patches linux-libre-5.9-pristine-source
(list %boot-logo-patch
@@ -565,6 +582,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.10
+ (make-linux-libre-headers* linux-libre-5.10-version
+ linux-libre-5.10-source))
+
(define-public linux-libre-headers-5.9
(make-linux-libre-headers* linux-libre-5.9-version
linux-libre-5.9-source))
@@ -856,17 +877,23 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.10
+ (make-linux-libre* linux-libre-5.10-version
+ linux-libre-5.10-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
+(define-public linux-libre-version linux-libre-5.10-version)
+(define-public linux-libre-pristine-source linux-libre-5.10-pristine-source)
+(define-public linux-libre-source linux-libre-5.10-source)
+(define-public linux-libre linux-libre-5.10)
+
(define-public linux-libre-5.9
(make-linux-libre* linux-libre-5.9-version
linux-libre-5.9-source
'("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-version linux-libre-5.9-version)
-(define-public linux-libre-pristine-source linux-libre-5.9-pristine-source)
-(define-public linux-libre-source linux-libre-5.9-source)
-(define-public linux-libre linux-libre-5.9)
-
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source
@@ -1023,8 +1050,8 @@ It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-with-bpf
(let ((base-linux-libre
(make-linux-libre*
- linux-libre-5.9-version
- linux-libre-5.9-source
+ linux-libre-5.10-version
+ linux-libre-5.10-source
'("x86_64-linux" "i686-linux" "armhf-linux"
"aarch64-linux" "riscv64-linux")
#:extra-version "bpf"