summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-11 00:33:24 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-24 23:31:29 +0100
commit654de94e74547f61a0996cae70ddba2826bfd8d4 (patch)
treeed5aa40f7fd90bb6f560dcec6f3451d5f4e3322b /gnu/packages/linux.scm
parenteac54126fbb0712a436eaa1b152a55efb32046ab (diff)
downloadguix-patches-654de94e74547f61a0996cae70ddba2826bfd8d4.tar
guix-patches-654de94e74547f61a0996cae70ddba2826bfd8d4.tar.gz
gnu: grub: Support for the Hurd.
* gnu/packages/virtualization.scm (qemu)[supported-systems]: Remove the Hurd. * gnu/packages/linux.scm (mdadm)[supported-systems]: Likewise. (lvm2)[supported-systems]: Likewise. (fuse)[supported-systems]: Likewise. * gnu/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it. [inputs, native-inputs]: Remove non-supported dependencies on non-supported systems. Fixes build for the Hurd.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 69c2818355..b73b86b0e8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2401,6 +2401,7 @@ processes currently causing I/O.")
(("-DFUSERMOUNT_DIR=[[:graph:]]+")
"-DFUSERMOUNT_DIR=\\\"/var/empty\\\""))
#t)))))
+ (supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://github.com/libfuse/libfuse")
(synopsis "Support file systems implemented in user space")
(description
@@ -3009,6 +3010,7 @@ time.")
;; The tests use 'mknod', which requires root access.
#:tests? #f))
+ (supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://sourceware.org/lvm2/")
(synopsis "Logical volume management for Linux")
(description
@@ -3920,6 +3922,7 @@ MPEG-2 and audio over Linux IEEE 1394.")
(delete 'configure))
;;tests must be done as root
#:tests? #f))
+ (supported-systems (delete "i586-gnu" %supported-systems))
(home-page "http://neil.brown.name/blog/mdadm")
(synopsis "Tool for managing Linux Software RAID arrays")
(description